[mythtv-users] QSqlDatabase: QMYSQL3 driver not loaded

Juergen Sachs juergen-sachs at gmx.de
Sun Sep 10 20:17:00 UTC 2006


until this morning I run mythtv svn rev 10946 which run quiet well.
Today I decided to update and made:
- svn up (now rev 11110)
- make dist clean
- configure (taking default values)
- qmake mythtv.pro
- make
- make install

and to test all I tried:
and got the following:
2006-09-10 22:05:41.430 Using runtime prefix = /usr/local
/usr/lib/libmysqlclient.so.14: undefined symbol:
QSqlDatabase: QMYSQL3 driver not loaded
/usr/lib/libmysqlclient.so.14: undefined symbol:
/usr/lib/libmysqlclient.so.14: undefined symbol:
QSqlDatabase: available drivers:
2006-09-10 22:05:41.493 New DB connection, total: 1
2006-09-10 22:05:41.493 Unable to connect to database!
2006-09-10 22:05:41.493 No error type from QSqlError?  Strange...
QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2006-09-10 22:05:41.546 DB Error (KickDatabase):
Query was:
No error type from QSqlError?  Strange...
2006-09-10 22:05:41.598 Failed to init MythContext, exiting.

I guess this is something in my configuration, but I don't know what, since 
the previous version worked.

Since with the old rev 10946 all worked, I should have iunstalled all needed 
mysql and qt files. I also find no note, that I have to take care about some 

can someone give me a hint what is going on ?

My system:
Suse 9.3

Thanks a lot

More information about the mythtv-users mailing list