[mythtv-users] "IOBOUND - blocking" and then "Couldn't read data from the capture card in 15 seconds."

Michael T. Dean mtdean at thirdcontact.com
Sat Sep 9 23:39:35 UTC 2006

On 09/09/06 05:16, Francesco Peeters wrote:

>On Sat, September 9, 2006 10:27, Michael T. Dean said:
>>On 09/08/06 08:36, Francesco Peeters wrote:
>>>So I am not sure which is causing which, but I have a MythTV box (0.18)
>>>Ubuntu, and once in a while I get:
>>><t+00> IOBOUND - blocking in ThreadedFileWriter::Write()
>>><t+15> Couldn't read data from the capture card in 15 seconds.
>>>Unable to write to client socket, as it's no longer there
>>>The card is a PVR250. I am using an external USB2 250 GB harddisk (WD
>>>MyBook) for the data.
>>>When this happens, the frontend hangs up. If I then kill and restart the
>>>frontend, all is fine again...
>>>I was unable to find much on IOBOUND using Google, so I was hoping maybe
>>>someone on the list had encountered and solved this?...
>>Yeah.  It's solved by using a current version of Myth.  (0.20 will be
>>out very soon.)
>Kewl and not kewl!
>Kewl: There's a solution!
>Not Kewl: I have to move away from Ubuntu's standard repo's for Myth...
>Ah well... I may just go for the CVS version then and compile myself...   :-/
>First I'll check whether there are any plans to upgrade the official deb's
>soon...   ;-)

Well, right now, 0.19 is current and 0.18 is ancient (0.19 is an 
antique).  So, if they don't have 0.19, I doubt they plan to go to 0.20.

My hunch, though, is that someone who uses Ubuntu could tell you how to 
get 0.19 because I know a /lot/ of Ubuntu users have 0.19 (or 0.19-fixes)...


More information about the mythtv-users mailing list