[mythtv-users] MythTV works, but channels off by one, XAWTV doesn't work

Matt Emmott memmott at gmail.com
Mon Sep 4 02:31:09 UTC 2006

Hi everybody!

I've been battling my MythTV install for a week now, and I've almost
got it. However, I'm having some last minute issues with my TV tuner,
and I'm hoping you guys can point me in the right direction. My system
consists of the following:

Fedora Core 4
2.6.17-1.2142_FC4 kernel
ASUS A7VBX-MX SE motherboard (Nforce4 chipset, I believe)
Hauppauge WinTV 38101 rev B426 tuner card, Conexant 878A chip

Here's the issue: All channels in MythTV are off by one. It says I'm
on channel 5 when I'm on 6, etc. Running TVTime, I have no problems...
Channels display what they really are, and everything seems ok. Trying
to launce XAWTV, however, just gives me a blue screen. I've tried
ftvco to determine the exact configuration, but when I run it I get
this error:

ERROR: Module bttv is in use by bt878
FATAL: Error inserting tuner
Unknown symbol in module, or unknown parameter (see dmesg)
trying: tuner type=0 --- bttv card=26 pll=0
This is xawtv-3.95, running on Linux/i686 (2.6.17-1.2142_FC4)

...And the screen is always blue no matter what I do. Hey, that rhymed.

My modprobe.conf looks like this:

alias eth0 via-rhine
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/m
odprobe -r --ignore-remove snd-via82xx
alias char-major-81 bttv
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Finally, I set up a .xawtv file in my mythtv user's home folder with
the following (I'm in the US, with coax cable plugged directly into
the card):

ratio = 4:3
freqtab = us-cable
pixsize = 320 x 240
pixcols = 1
jpeg-quality = 75
keypad-ntsc = no
keypad-partial = yes
osd = yes
norm = NTSC
input = television
capture = over
color = 45%
contrast = 42%

I'm no Linux expert when it comes to drivers and such, but I am
learning! I was hoping somebody could tell me what I'm missing -
hopefully it's just a dummy error, but I'm running out of ideas, and
could appreciate some help. Thanks in advance!

More information about the mythtv-users mailing list