[mythtv-users] bt878 sound issue on Fedora Core 5

Andrew Martin andrewcmartin at msn.com
Sat Sep 2 04:16:18 UTC 2006

Thanks for the help.  How do I verify that WinTV is outputting audio?  Also, 
how do I use alsamixer to turn on DAC?  I see references to "Digital Audio 
Capture" in the F2 menu of alsamixer, but nowhere do I see how to turn 
things on and off.  Sorry, it's been a couple years since I messed with this 

Thanks again,

>From: "Bryan Cromwell" <bcromwell.mailinglists at gmail.com>
>Reply-To: Discussion about mythtv <mythtv-users at mythtv.org>
>To: "Discussion about mythtv" <mythtv-users at mythtv.org>
>Subject: Re: [mythtv-users] bt878 sound issue on Fedora Core 5
>Date: Thu, 31 Aug 2006 01:03:17 -0400
>Verify your WinTV is outputing audio, if it is use alsamixer to turn on up
>DAC and unmute Ext Amplifer. Then set your record device to mic or line in
>depending on when input you used on you sound card, then mute the record
>device (Or your audio will not be in sync with your video)
>On 8/30/06, Andrew Martin <andrewcmartin at msn.com> wrote:
>>I just installed Fedora Core 5 and am having trouble getting sound on my
>>Hauppauge WinTV (bt878) card to work. Video works fine, I just can't hear
>>anything!   I previously ran Gentoo (2 years old) on this system and was
>>able to get MythTV working fine.  Here are some of the detals:
>>- Audio works fine on the system otherwise (I can play mp3s, for
>>- I've tried messing with all the sliders on alsamixer and kmix, to no
>>- Tvtime also plays video, but no sound.
>>- I hear a 'click' when I start tvtime, as if the sound is about to start,
>>but then I can't hear anything.
>>- There are two sound cards on the system, but I'm not using the
>>- I've tried the modifications to modprobe.conf described here:
>>Any ideas would be greatly appreciated.  Below is the output from lsmod,
>>well as the relevant content from dmesg and modprobe.conf
>>[root at juanita ~]# lsmod|grep bt
>>bt878                  11529  0
>>snd_bt87x              15561  0
>>snd_pcm                83781  5
>>bttv                  176181  1 bt878
>>video_buf              26181  1 bttv
>>ir_common              27333  1 bttv
>>compat_ioctl32          1601  1 bttv
>>i2c_algo_bit            8905  1 bttv
>>v4l2_common            15553  3 tuner,msp3400,bttv
>>snd                    55237  17
>>btcx_risc               5193  1 bttv
>>tveeprom               14673  1 bttv
>>videodev                9537  1 bttv
>>snd_page_alloc         10569  4 snd_bt87x,snd_intel8x0,snd_emu10k1,snd_pcm
>>i2c_core               22209  7
>>**** /var/log/dmesg ****
>>bttv: driver version 0.9.16 loaded
>>bttv: using 8 buffers with 2080k (520 pages) each for capture
>>bt878: Unknown symbol bttv_read_gpio
>>bt878: Unknown symbol bttv_write_gpio
>>bt878: Unknown symbol bttv_gpio_enable
>>e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
>>bttv: Bt8xx card found (0).
>>bttv0: Bt878 (rev 2) at 0000:02:01.0, irq: 209, latency: 64, mmio:
>>bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
>>bttv0: using: Hauppauge (bt878) [card=10,autodetected]
>>bttv0: gpio: en=00000000, out=00000000 in=00ffffdb [init]
>>bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
>>bttv0: Hauppauge eeprom indicates model#61381
>>bttv0: using tuner=21
>>bttv0: i2c: checking for MSP34xx @ 0x80... found
>>bttv0: i2c: checking for TDA9875 @ 0xb0... not found
>>bttv0: i2c: checking for TDA7432 @ 0x8a... not found
>>bttv0: i2c: checking for TDA9887 @ 0x86... not found
>>bttv0: registered device video0
>>bttv0: registered device vbi0
>>bttv0: registered device radio0
>>bttv0: PLL: 28636363 => 35468950 .. ok
>>**** /etc/modprobe.conf ****
>>alias snd-card-0 snd-emu10k1
>>options snd-card-0 index=0
>>options snd-emu10k1 index=0
>>remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
>>/sbin/modprobe -r --ignore-remove snd-emu10k1
>>alias snd-card-1 snd-bt87x
>>options snd-card-1 index=1
>>options snd-bt87x index=1
>>remove snd-bt87x { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
>>/sbin/modprobe -r --ignore-remove snd-bt87x
>>#alias snd-card-1 snd-intel8x0
>>#options snd-card-1 index=1
>>#options snd-intel8x0 index=1
>>#remove snd-intel8x0 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; };
>>/sbin/modprobe -r --ignore-remove snd-intel8x0
>>Thank you,
>>Check the weather nationwide with MSN Search: Try it now!
>>mythtv-users mailing list
>>mythtv-users at mythtv.org

>mythtv-users mailing list
>mythtv-users at mythtv.org

Get the new Windows Live Messenger!   

More information about the mythtv-users mailing list