[mythtv-users] Seeking advice with firewire

Michael T. Dean mtdean at thirdcontact.com
Fri Sep 1 01:02:24 UTC 2006

On 08/31/06 20:30, mythtv at timekiller.org wrote:

> I'll cut straight to the meat of my problem. I have a backend box 
> connected to a 62xx motorola cable box. I use firewire to record any 
> unencrypted channels I can. I also set up a second input/video source 
> for all te channels I can't get over firewire. The second input uses 
> S-Video, and I setup my zap2it accounts so no channel exists on BOTH 
> inputs
> Now here's my problem:
> The backend sees this as 2 separate tuners, even though they are 
> connected to the same device. Obviously this is a problem if say, I 
> want to record something on channel 5, and on HBO simultaniously :) 
> What ,happens is a race condition where the box gets 2 channel change 
> commands, and tries to record off both firewire, and S-Video.
> I figure I'm not the first to have this issue, and am curious how 
> others have dealt with it. I am thinking about making a channel change 
> wrapper that checks the status of the other tuner, and exits with 
> status code 1 if the tuner is in use. But if 2 recordings start at the 
> same time, it will still have the same race condition !

I'm pretty sure the only way to deal with it currently is to get a 
separate (dedicated) STB for each source.  There was talking of adding 
an ability to specify a usage scenario like this, but it won't be in 0.20.


More information about the mythtv-users mailing list