[mythtv-users] lirc problems

Chris Rouch chris.rouch at gmail.com
Tue Oct 17 14:20:51 UTC 2006

On 10/16/06, wilkinnh at netscape.net <wilkinnh at netscape.net> wrote:
> i have everything installed and working for my mythtv box...except lirc. its
> getting really frustrating. i've tried just about everything i can google
> and i can't get anything to work. i tried the lirc mailing list and no one
> wanted to help me there...so i'm hoping i can get some help on here. for
> starters, i ordered an ir receiver from irblaster.info. i know it works
> cause i could do mode2 and get the pulse and space things to work when i
> push a button with a remote. that's as much progress as i could get. i'm
> suspecting that i have a driver issue, but i don't know how to resolve it.
> one problem could be that i don't know how to configure the lirc setup. if i
> try and do the home-brew, it says it can't find the kernel source, and i
> have no idea where or how to set that up. i tried downloading the source and
> installing it, but that didn't change anything. i tried bypassing the lirc
> setup and 'fooling' it into using some other remote...that didn't work
> either. i'm trying to use a sony remote and i found one i think will be
> compatible with my remote in the remotes package i got from the lirc page.
> its just the middle step. i'd like to be able to run irrecord or irw and see
> some results, but i get errors with those as well. any help i can get would
> be greatly appreciated! thanks
>  nate

If this is a serial port reciever then you probably need something
like the following in /etc/modprobe.conf:

alias char-major-61 lirc_serial
options lirc_serial irq=4 io=0x3f8
install lirc_serial /bin/setserial /dev/ttyS0 uart none ;
/sbin/modprobe --ignore-install lirc_serial

(that should be 3 lines, in case the last one has wrapped).

Then install the appropriate rpms from atrpms (or otherwise install
lirc if you don't use rpms), and use irrecord to setup
/etc/lircd.conf. I found I had to do this last step even though I
could get a predefined lircd.conf that was supposed to match my
remote. YMMV.

I think I originally got all this information from Jarod's guide.



More information about the mythtv-users mailing list