[mythtv-users] recordings cut off early especially when watching recoding in progress

Nick knowledgejunkie at gmail.com
Fri Oct 13 10:57:22 UTC 2006

On 12/10/06, McNally <mcnallychris at pobox.com> wrote:
> Hi,
> I'm using mythtv 0.20.  When I watch recording in progress, such as a
> baseball game, I begin watching about 40 minutes after the start, fast
> forward through commercials and other junk,  and find that the actual
> recording seems to have stopped soon after i started watching. This has
> happened twice already to me. I see from the logs that there seems to be
> a DMA error and it may be IVTV related. Other recordings have ended much
> sooner than scheduled and there is an error in the Myth log.
> I am using an ASUS A8N-VM CSM mainboard with an AMD Sempron  which has
> NVIDIA nforce and gforce chipsets. The backend and frontend are the same
> box. I am using ext3. The CPU from top is around 90% when watching
> recordings. I have sections of the logs below.  Thanks in advance.
> ivtv version
> ivtv:  version 0.7.0 (tagged release) loading
> ivtv:  Linux version: 2.6.17-1.2142_FC4 mod_unload 686 REGPARM 4KSTACKS
> gcc-4.0

Try upgrading to ivtv 0.7.1 which has a fix for DMA problems like this
- from the ivtv changelog:

IVTV changes:

0.7.1 stable release
	- Add getopt support to test/vbi. Add new timeout option.
	- Fix South African broadcast frequency table.
	- Detect and workaround DMA offsets that can be introduced by
	  a DMA error.
	- Sliced VBI always uses PIO, never DMA.


MythTV Official wiki:
MythTV users list archive:

More information about the mythtv-users mailing list