[mythtv-users] nforce4 digital sound

Brad DerManouelian myth at dermanouelian.com
Sun Oct 8 18:24:37 UTC 2006

On Oct 8, 2006, at 11:12 AM, Rob Adams wrote:

> Weird; everything I've seen indicated that this needed to be set to  
> 0 in
> order to get any sound.  Regardless, I've tryed adjusting it to  
> maximum
> but it still doesn't work.  Any other suggestions?  I'm at the end  
> of my
> rope here.

I was trying to find the original message in the archived, but  
couldn't so I pulled this out of my old mail:

> After having tried previously and given up, I gave onboard S/PDIF  
> another
> shot
> last night.  I updated the kernel to the latest and greatest and  
> went over
> some
> of the other messages in this thread.
> Try the following:
> 1) Delete /etc/asound.conf, if present...you don't need it.
> 2) In alsamixer, make sure these settings are as follows:
>    IEC958: unmuted
>    IEC958 Playback AC97-SPSA: 0%
>    IEC958 Playback Source: PCM
>    PCM: unmuted (level shouldn't matter, but mine is at 77%)
>    Master: unmuted (level shouldn't matter, but mine is at 77%)
> 3) Test PCM audio:
>    aplay /dev/urandom
>    You should get white noise.
> 4) Test AC3 passthrough:
>    mplayer -ao alsa -ac hwac3, dvd://

I've got a very simple conf file like this:
[mythtv at mythtv ~]$ more /etc/asound.conf
#Generated by system-config-soundcard, do not edit by hand
#DEV 2
pcm.!default { type hw card 0 device 2 }
ctl.!default { type hw card 0 }

aslamixer has:
IEC958 Playback AC97-SPSA in the 0 position
IEC958 Playback Source set to PCM

This works on my optical port. I've never tried it with coax. It's  
easier to diagnose optical since you can see if there's light coming  
out of it when you have the correct port active.

More information about the mythtv-users mailing list