[mythtv-users] 0.20 schema upgrade failed

Michael T. Dean mtdean at thirdcontact.com
Sat Oct 7 20:59:18 UTC 2006

On 10/07/06 16:23, Peter Bienstman wrote:

>I upgraded from 0.19 to 0.20 (Actually the Gentoo 0.20_p11444 version), but 
>when I start mythfrontend, I get this:

>Database error was:
>Table 'mythconverg.recordedprogram' doesn't exist

Let me guess.  You did a partial restore of the database ( 
http://mythtv.org/docs/mythtv-HOWTO-23.html#ss23.7 ) after the upgrade 
rather than a full restore ( 
http://mythtv.org/docs/mythtv-HOWTO-23.html#ss23.5 )?

If that's not the case, you may have exported a corrupt database whose 
recordedprogram table couldn't be opened (and, therefore, wasn't 
exported).  Fortunately, recordedprogram isn't critical data (it's 
automatically regenerated).

After a bit more information on what constitutes "the upgrade," I can 
give you more info on possible approaches for getting a working database.


More information about the mythtv-users mailing list