[mythtv-users] Mythfilldatabase - odd bug - will not insert data for a new channel

drbob drbob at gmx.co.uk
Wed Oct 4 22:10:15 UTC 2006

I'm trying to switch two channels to use xmltv data: BBC Four and BBC 
Parliament, since eit isn't working for me on these channels. I already 
successfully collect data for two of my channels via xmltv (abc1 and 

Here is what I did:

I added the channel ids to the tv_grab_uk_rt.conf file, unchecked the 
use onair guide boxes in mythweb and added the xmltv ids in the correct 

Whatever I tried to do: mythfilldatabase wouldn't recognise the new 
channels. It still updates channel five and abc1, but won't put the BBC 
channel data into mysql. I've run tv_grab_uk_rt separately and it _is_ 
downloading the program data for the BBC channels.

Running "mythfilldatabase --manual" it only asks me about abc1 and 
channel5, totally ignoring the new xmltv ids in the channels table.

I finally managed to get the data into mysql by saving the output of 
tv_grab_uk_rt to a  file - uk.xml and running the command:

 mythfilldatabase --file 1 -1 uk.xml

as suggested on the mythfilldatabase wiki page for unsupported 
countries. However mythfilldatabse still won't update the data for the 
BBC channels in it's regular automatic runs.

The only difference I can see between the entries for the channels in 
the sql table is that abc1 and channel5 have a value in the freqid 
field, whilst the BBC channels don't - this shouldn't matter should it?

More information about the mythtv-users mailing list