[mythtv-users] Matrix: Revolutions Rip problems

David Snider dsnider at thesniderpad.com
Sun Oct 1 13:47:36 UTC 2006

On Oct 1, 2006, at 7:23 AM, Al Banks wrote:

> Just tried with ogle - English.
> Now I'm really confused!  :-)
> -Al

Have you tried mplayer with the -aid flag?  Generally, this works for  
me... I've had this problem before and usually, it's easier to find  
the exact audio stream you want (usually 128, I think) and strip  
everything else out.

Here is the procedure that usually works for me, you'll wind up with  
a VOB file with just one audio track...

Step 1. Dump the Audio
         You will want to make sure you have the correct audio  
track.  To do
         this, run mplayer with -v and grep for "Found Audio Track".   
Then try
         mplayer with the correct -aid flag.  For example:

         mplayer Shrek_2_US_16x9.vob -dumpaudio -dumpfile audio.ac3
         -benchmark -vo null -aid 128

Step 2. Dump the Video
         mplayer -ao null Shrek_2_US_16x9.vob -dumpvideo -dumpfile  
shrek2.mp2 -benchmark

Step 3. Combine the two
         mplex -f8 -o shrek.vob /mnt/c/Temp/shrek2.mp2 /mnt/c/Temp/ 

More information about the mythtv-users mailing list