[mythtv-users] Gentoo / MythTV question

Brian Wood beww at beww.org
Sun Nov 12 14:40:20 UTC 2006

On Nov 12, 2006, at 7:26 AM, Robin Hill wrote:

> On Sun Nov 12, 2006 at 08:32:40AM -0500, Phil Bridges wrote:
>> 'm doing an upgrade to a new MythBox, and I figured I'd try Gentoo on
>> the machine.  Unfortunately, everytime I go to emerge MythTV, it  
>> wants
>> to fetch the 0.19 version.  Does anyone have any pointers as to  
>> how to
>> get the 0.20 version?
> The MythTV packages are still marked as unstable, so you'll need to
> override this.  Create /etc/portage/packages/keywords/mythtv (if you
> already have a file /etc/portage/packages/keywords then you can use  
> that
> instead - it's a bit cleaner if you separate them by usage though) and
> add the following lines:
> <media-tv/mythtv-0.21
> <x11-themes/mythtv-themes-0.21
> <media-plugins/mytharchive-0.21
> <media-plugins/mythbrowser-0.21
> <media-plugins/mythcontrols-0.21
> <media-plugins/mythdvd-0.21
> <media-plugins/mythflix-0.21
> <media-plugins/mythgallery-0.21
> <media-plugins/mythgame-0.21
> <media-plugins/mythmusic-0.21
> <media-plugins/mythnews-0.21
> <media-plugins/mythphone-0.21
> <media-plugins/mythvideo-0.21
> <media-plugins/mythweather-0.21
> <www-apps/mythweb-0.21
> This'll enable any version of MythTV (and plugins) less than 0.21.   
> This
> should include any versions based on 0.20-fixes SVN but exclude  
> anything
> from SVN head (which should go in as 0.21_pre).
> You may need to add other applications to this list, if they're
> dependencies for MythTV.  In this case, add them with specific  
> versions
> (e.g. =media-libs/libdts-0.0.2-r5) as you'll probably want to stick to
> stable versions where possible.

This would work as well, up until Myth gets upgraded past 0.21.

Of course if you wanted to live dangerously you could just put an  
"ACCEPT_KEYWORDS= "~(arch)" directive into your /etc/make.conf file,  
but that would cause *all* unstable packages to be accepted.

You probably want to make sure your system is up to date before  
installing Myth:

emerge --sync
emerge -avuDN world

But if you're running Gentoo you really have to study all the  
possibilities that the masking system and portage in general allow.

More information about the mythtv-users mailing list