[mythtv-users] WOL doesn't seem to work, any pointers?

Ivan Kabaivanov chepati at yahoo.com
Mon Nov 6 06:43:42 UTC 2006

On Monday 06 November 2006 01:24, Kevin Kuphal wrote:
> Chad wrote:
> > I've read a bunch of stuff on using WOL including a mini-How-TO:
> > http://gsd.di.uminho.pt/jpo/software/wakeonlan/mini-howto/wol-mini-howto-
> >3.html
> >
> > It seems to be a *very* simple process, but I'm not having much luck.
> > I'm sure that the test system I'm trying to get this working on is WOL
> > capable (a Commell LV-667T) and I've tried 2 of the 'tools' listed on
> > that mini How-TO.  The first one I tried was:
> >
> > wakeonlan
> >
> > The command is fairly simple:
> > wakeonlan aa:bb:cc:dd:ee:ff
> >
> > Where aa:bb:cc:dd:ee:ff is the MAC address of the ethernet port on the
> > Commell.  I'm running that command from another system on my LAN.  By
> > default, wakeonlan uses and just for kicks I've also
> > tried
> >
> > I've also tried:
> >
> > ether-wake
> >
> > The only thing I got from it was that it needed to be run by root, so
> > I did, but still the system didn't wake up.
> >
> > I've set the setting in the BIOS to "Wake on LAN/Ring" and I've got
> > the ethernet cable plugged into the ethernet port (there are 2, it's
> > plugged into ethernet_1 and I've tried ethernet_2 just to make sure,
> > no difference).
> >
> > My basic LAN info is:
> > inet addr:  Bcast:  Mask:
> >
> > That's from ifconfig  The router sits at (smoothwall) and
> > the 2 machines I'm trying to test this with is connected to the same
> > switch on my LAN side of the router (not on the orange or red
> > interfaces, it's all green and further LAN segmented).
> >
> > I'm not sure what other kind of info you may need, but any pointers at
> > this point would be helpful.
> >
> > Thanks!
> >
> > PS:  I figure this is MythTV related since I'm trying to get this
> > working so I don't have to have my MythTV backends up 24/7 for no real
> > good reason.  Also, I'd really really really prefer to not use nvram,
> > WOL seems much more elegant and... safe.
> Are you using the mac address or the IP address?  When the system is
> sleeping, it doesn't have an IP so you use the MAC (hardware) address of
> the card:
> [root at mythtv root]# ifconfig
> eth0      Link encap:Ethernet  HWaddr 00:04:5A:87:F5:65
>           inet addr:  Bcast:  Mask:
> The HWaddr is what you want like:
> wakeonlan 00:04:51:87:F5:65
> Kevin


further to what Kevin wrote (use MAC, not IP), make sure you set your NIC into 
WOL state.  Many NIC drivers do this by default, but you make have to do it 
manually for others.  Use ethtool to check/set NIC parameters.  The URL is: 

Here's what ethtool reports on my machine which works with WOL:

[root at localhost /]# ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: umbg
        Wake-on: g
        Current message level: 0x00000007 (7)
        Link detected: yes
[root at localhost /]#

You need at least g (wake from magic packet) in Wake-on: for WOL to work.  If 
you discover that your driver doesn't set the NIC into any WOL state, do it 
manually like so:

[root at localhost /]# ethtool -s eth0 wol g

Once you get it working, put this in one of the /etc/rc.d/init.d scripts -- it 
depends what distribution you're using.


More information about the mythtv-users mailing list