[mythtv-users] skipping forward not working right anymore

Michael T. Dean mtdean at thirdcontact.com
Mon Nov 6 05:05:11 UTC 2006

On 11/05/2006 04:12 PM, William Munson wrote:
> Marco Nelissen wrote:
>> All of a sudden skip-forward during playback doesn't work right anymore.
>> It used to be instantaneous, but now whenever I skip there is a very
>> noticable delay and a distortion of the image that takes several
>> seconds to clear up.
>> Skipping backwards is still fine, and if I skip back and then forward
>> again, it is fine too. It's as if reading from disk has gotten extremely
>> slow, except it isn't: I still get over 50MB/second reading from disk.
>> Anyone ever seen symptoms like this?
> I could be all wrong but it sounds similar to the skip problem I was 
> having. Somehow my seek tables on some recordings got screwed up and 
> would cause various playback problems. What fixed it for me was to run 
> mythcomflag with the --rebuild option. Although it took a while I just 
> had it rebuild the seek tables of all recordings with --rebuild --all
> Try it on one of your problem recordings.
> Another thought.... Are you running the optimize_mythdb.pl script out of 
> the contribs folder? That could also be the answer to your troubles.

Great advice, but make sure you run optimize_mythdb.pl /first/ (and then 
set up a daily cron job to execute optimize_mythdb.pl (as described in 
the comments at the top of the script)).  Otherwise, if your 
recordedseek table is corrupt, running "mythcommflag --rebuild" is 
simply wasting processor cycles (and accomplishing nothing useful, and 
possibly making matters worse).


More information about the mythtv-users mailing list