[mythtv-users] no sound -Solved(sort-of)

Paul Cnudde cnuddep at rogers.com
Thu Mar 23 14:16:42 UTC 2006

Well, I finally managed to get sound going in Myth, but it was hardly an elegant or clean fix.  An appropriate analogy perhaps would be opening a wine bottle with a sledgehammer, hey whatever works...
After trying every combination of settings in mythfrontend with no success, I decided to uninstall the debian package and compile from source.  This was fairly straight forward as was setting up the mysql database.   I didn't have any issues until I ran mythtv-setup at which point it started complaining about not being able to find themes.  The only screen I got was the final one asking me to run mythfilldatabase.  I couldn't run mytfilldatabase because I hadn't configured mythbackend I was sort of stuck in a loop.  Not being very sure what my options were at this point I decided to reinstall the debian package (leaving the one I compiled from source and installed in place).  This also started complaining about various components not yet being configured.  I gave it a shot and ran mythtv-setup went through the configuration no problem. Ran mythfilldatabase no problem.  Launched mythbackend no problem.  launched mythfrontend no problem.  Configured frontend and a couple of minutes
 later was watching live tv with sound.

I wish I was posting a "this is how to fix it" message but as you can see  my "fix" was rather ugly and probably wouldn't work for any sane person.  However for those trying to do this and having audio problems,  here is the sound configuration in mythfrontend which worked for me:
Audio Output Device: ALSA:default
Mixer Device: default
Mixer Control: Master
Also make sure esd is not configured to start when Gnome starts.  Make sure your card is producing sound outside of Myth before you even attempt configuring myth. Using the IVTV utils is probably the best and simplest method of trouble shooting. And of course make sure you can play mp3s wavs etc using your favorite player.

Looks like those years on the help desk paid off after all!

Thanks again to all who replied to my oringinal post.
Paul Cnudde <cnuddep at rogers.com> wrote: Thanks for your reply.  When I installed Mythtv a user was created- 'mythtv'.  I assume this is the context under which it runs( how can I be sure?) althoughI start the backend as root from a command line and start the front end as myself from a command line.  Anyway, following your suggestion,  logged in as root, mythtv and myself I can get sound playing mp3's mpegs wavs etc using various programs(except myth).  I'm guessing that this should be the case

What might point me in the right direction is if someone with a similar setup as mine could post a working configuration. ie. what ALSA/OSS components were compiled or included as modules in the kernel.  what mixer levels were set, and what needs to be filled in in mythforntend for sound device  and mixer. 
I know I'm just missing something, but I can't figure out what it is

I also read somewhere that I might require a .asoundrc file.  What is this, where does it go and where  can I get one?
thanks again
Nick Rout <nick at rout.co.nz> wrote: 
On Tue, 21 Mar 2006 22:04:14 -0500 (EST)
Paul Cnudde wrote:

> I can't for the life of me figure out why I can't get mythtv to produce any sound.
> I managed to get ivtv working. If I do cat /dev/video0 > test,mpg then I get a short mpg which contains audio so I know my card is working correctly (its a pvr-500 with the hardware encoder so no need to patch it in to my sound card)
> I can play wav files and mp3s etc no problem using totem.
> I have tried the setting the following devices in mythfrontend:
> ALSA:default
> /dev/dsp
> /dev/adsp (i dunno it was in the list)
> I have tried these with the different combinations of mixers suggested:
> /dev/mixer
> default
> /dev/mixer1
>  I have played around with the alsamixer  and the gnome mixer.  I have tried capturing on all the inputs, yet I get no sound.  looking back through the archives this seems to be a common problem but unfortunately not many people seem to post their solutions.  I'm a bit of newbie with linux and perhaps bit off more than I can chew attempting to set up mythtv 0.19 as one of my first projects.  If someone could provide me with *detailed* trouble shooting steps I'd be very appreciative.  I'm running debian with a 2.6.15 kernel.  My sound card is an onboard Nvidia nforce2
> If I manage to fix this I will post my solution to this list
> thanks in advance for your help.
> Paul

what user does mythtv run as? Does */that user/* have the ability to
output sound? (su - to that user then try running some movies and see if
it outputs sound).

Nick Rout 

mythtv-users  mailing list
mythtv-users at mythtv.org

mythtv-users mailing list
mythtv-users at mythtv.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060323/818bb134/attachment.htm 

More information about the mythtv-users mailing list