[mythtv-users] cx88-dvb won't load

Mark Johannessen mfjlaw at gmail.com
Tue Mar 21 04:32:12 UTC 2006

I tried both renaming and doing a chmod 000 on the files tveeprom.ko,
tuner.ko, and tda9887.ko that were in three directories on my FC4
system, for example:

# locate tveeprom.ko

After this, I did a depmod -a and rebooted and still was unable to do
a /sbin/modprobe -v cx88-dvb without fatal complaints.  The dmesg
looks like this:

cx88xx: disagrees about version of symbol tveeprom_hauppauge_analog
cx88xx: Unknown symbol tveeprom_hauppauge_analog
cx8802: Unknown symbol cx88_reset
cx8802: Unknown symbol cx88_wakeup
cx8802: Unknown symbol cx88_risc_stopper
cx8802: Unknown symbol cx88_print_irqbits
cx8802: Unknown symbol cx88_shutdown
cx8802: Unknown symbol cx88_core_irq
cx8802: Unknown symbol cx88_sram_channels
cx8802: Unknown symbol cx88_sram_channel_dump
cx8802: Unknown symbol cx88_sram_channel_setup
cx8802: Unknown symbol cx88_free_buffer
cx8802: Unknown symbol cx88_boards
cx8802: Unknown symbol cx88_risc_databuffer
cx88_dvb: Unknown symbol cx8802_fini_common
cx88_dvb: Unknown symbol cx88_call_i2c_clients
cx88_dvb: Unknown symbol cx88_core_put
cx88_dvb: Unknown symbol cx88_core_get
cx88_dvb: Unknown symbol cx8802_resume_common
cx88_dvb: Unknown symbol cx8802_buf_prepare
cx88_dvb: Unknown symbol cx8802_init_common
cx88_dvb: Unknown symbol cx88_free_buffer
cx88_dvb: Unknown symbol cx88_boards
cx88_dvb: Unknown symbol cx8802_buf_queue
cx88_dvb: Unknown symbol cx8802_suspend_common

my /etc/modprobe.conf looks like this:

alias char-major-61 lirc_i2c
alias eth0 sk98lin
alias eth1 sk98lin
alias scsi_hostadapter sata_nv
alias snd-card-0 snd-ca0106
options snd-card-0 index=0
options snd-ca0106 index=0
remove snd-ca0106 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-ca0106
alias snd-card-1 snd-intel8x0
options snd-card-1 index=1
options snd-intel8x0 index=1
remove snd-intel8x0 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias char-major-81 ivtv
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
install lircd_i2c /sbin/modprobe ivtv; /sbin/modprobe --Ignore-install lirc_i2c
# nvidia kernel module
alias char-major-195 nvidia-1_0-7676
alias nvidia nvidia-1_0-7676
install cx88-atsc /sbin/modprobe cx8800;/sbin/modprobe
--ignore-install cx88-atsc
install cx88-dvb /sbin/modprobe cx8800;/sbin/modprobe --ignore-install cx88-dvb
install btcx-risc /sbin/modprobe tuner;/sbin/modprobe --ignore-install btcx-risc

I then tried to comment out in /etc/modprobe.conf both of the lines
that start with "install cx88-", and rebooted.  Then when I
# /sbin/modprobe -v cx88-dvb
I get:

WARNING: Error inserting cx88xx
Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting cx8802
Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting cx88_dvb
Unknown symbol in module, or unknown parameter (see dmesg)

I found that by removing ivtv (yum remove ivtv), I can get
/sbin/modprobe -v cx88-dvb to load and create the /dev/dvb directory,
but that breaks at least lirc for my PVR 350.  This at least confirms
that the issue is with ivtv.  It appears others have gotten cx88-dvb
to load by simply moving the three files above, but for some reason
that doesn't work for me.  I also tried re-ordering the loading of
ivtv, cx88_blackbird, cx88-dvb, and cx8800 with no luck.

Is there anything above that looks suspicious?


On 3/17/06, mrwester <mrwester at gmail.com> wrote:

>  It has to do with changes to ivtv in latest version... you can get it to work for now until ivtv gets fixed by hiding some modules.  See http://www.gossamer-threads.com/lists/ivtv/devel/28632?search_string=0.4.3%20and%;#28632

More information about the mythtv-users mailing list