[mythtv-users] First generation ATSC Air2PC PCI card + MythTV + Fedora Core 4 (FC4).

Jon Scheer wombat at scheerfun.org
Sat Mar 18 04:37:03 UTC 2006

Brian Webb wrote:
> All the required drivers are in the latest FC4 kernel, so if you
> update to the latest kernel it should "just work".

Thanks for the quick response.  That's good to know that it should work, 
and I did have partial success, but not enough to get a valid signal.

I do have a few questions:

(1) Do I have to be concerned about the firmware?  I downloaded it, 
created the directory /lib/firmware, and put the firmware file in there. 
  But did I need to do this?

(2) I do see the card when I do an 'lspci', and /var/log/dmesg shows the 
following :

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded 
flexcop-pci: will use the HW PID filter.
flexcop-pci: card revision 2
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
ACPI: PCI Interrupt 0000:00:0e.0[A] -> Link [LNKB] -> GSI 10 (level, 
low) -> IRQ 10
DVB: registering new adapter (FlexCop Digital TV device).
b2c2-flexcop: MAC address = 00:d0:d7:30:1c:d7
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
i2c_readbytes: i2c read error (addr 0a, err == -121)
b2c2-flexcop: i2c master_xfer failed
lgdt330x: i2c_read_demod_bytes: addr 0x59 select 0x02 error (ret == -121)
bcm3510: Revision: 0x1, Layer: 0xb.
b2c2-flexcop: found the bcm3510 at i2c address: 0x0f
DVB: registering frontend 0 (Broadcom BCM3510 VSB/QAM frontend)...
b2c2-flexcop: initialization of 'Air2PC/AirStar 2 ATSC 1st generation' 
at the 'PCI' bus controlled by a 'FlexCopIIb' complete
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

However, I see the following in /etc/modprobe.conf :

	alias eth3 b2c2-flexcop-pci

So does the system think it's really an Ethernet card?  Why the MAC 
address as reported by b2c2-flexcop?

(3) When I run mythtv-setup, and I go to the 'Capture Card Setup', if I 
choose the card type 'DVB DTV capture card (v3.x)', it looks like the 
card is in fact detected :

    DVB Card Number:   0
    Frontend ID:       Broadcom BCM3510 VSB/QAM frontend Subtype: A...
    Signal Timeout (msec):  500
    Tuning Timeout (msec):  3000

What is confusing me is that this is a first generation card (rev 02),
but is it OK that MythTV is treating this as a v3.x card?  Or does
the v3.x mean something completely different?

(4) I can go ahead and scan for channels, however the signal strength 
for every channel is 0.  Thus, I'm not sure if the signal is just really 
weak or if something is not configured properly.  I do have an HDTV 
setup box in the living room, and it picks up some HDTV channels, so I 
was thinking that I should get some signal strength (greater than 0)...?

I feel like I'm close, but....  :-/

Thank you for your time.


>>I'm trying to get a first generation ATSC Air2PC PCI card (Techsan
>>Broadcom BCM3510) working on a Fedora Core 4 (FC4) system, but I'm
>>having some issues.  I was wondering if anyone has any information or a
>>link to a web page that talks about getting such a card working with FC4
>>(for use with MythTV)...?  I've searched around and have found
>>information on getting the card working under other distributions, and
>>I've tried to mimic those instructions, but I'm still running into issues.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list