[mythtv-users] RingBuf error when watching live TV: Invalid file (fd 15)

hohenner at comcast.net hohenner at comcast.net
Mon Mar 13 03:33:11 UTC 2006

having an odd twist to this one,

When I run LiveTV on my monitor, it works fine, but when I turn on the TV out on my PVR 350 and try to watch on my TV, I get a black screen, the menus show up and after I've tried changing channels, I cannot get mythtv to come back to the main menu, hitting <esc> does nothing...

I'm getting RingBuf errors as well:
2006-03-12 19:11:33.462 TV: Attempting to change from None to WatchingLiveTV
2006-03-12 19:11:33.469 Using protocol version 26
2006-03-12 19:11:33.720 RingBuf(/myth/video/1052_20060312191133.mpg): Invalid file (fd 17) when opening '/myth/video/1052_20060312191133.mpg'. 12 retries remaining.
2006-03-12 19:11:34.221 RingBuf(/myth/video/1052_20060312191133.mpg): Invalid file (fd 17) when opening '/myth/video/1052_20060312191133.mpg'. 11 retries remaining.
0: start_time: 0.036 duration: 0.162
1: start_time: 0.026 duration: 0.130
stream: start_time: 0.289 duration: 1.913 bitrate=5790 kb/s
2006-03-12 19:11:36.659 AFD: Opened codec 0x8299e10, id(MPEG2VIDEO) type(Video)
2006-03-12 19:11:36.681 AFD: Opened codec 0x8281ca0, id(MP2) type(Audio)
2006-03-12 19:11:36.684 Opening audio device '/dev/dsp'.
2006-03-12 19:11:36.684 Opening OSS audio device '/dev/dsp'.
2006-03-12 19:11:36.945 TV: Changing from None to WatchingLiveTV
2006-03-12 19:11:36.962 Realtime priority would require SUID as root.
2006-03-12 19:11:36.966 Video timing method: USleep with busy wait
2006-03-12 19:11:40.858 TV: Attempting to change from WatchingLiveTV to None
2006-03-12 19:11:41.291 TV: Changing from WatchingLiveTV to None

I've looked at 

I'm running my frontend and backend on the same PC so I'm not using NFS,

I checked RecordFilePrefix, it is set to /myth/video (the folder where I'm storing my recordings, and files are showing up there...)

The one thing that I did that may affect this, I had created a user "mythic" when I installed Linux for myth, not realizing that the mythtv ID would be created. I've given mythic the same permissions as mythtv. Last time I logged in under the mythtv ID, I couldn't get myth to launch (in the setup screens I changed the ID to mythic). I didn't worry about it at the time because in the setup screens I changed the user id and passwords to mythic and it's password. Is the mythtv user used behind the scenes?


More information about the mythtv-users mailing list