[mythtv-users] HELP: I messed up my IR Blaster config, now it doesn't work

Daniel A Segel mythtv at archer-segel.com
Mon Mar 6 16:13:35 UTC 2006

I'm running a Gentoo-based MythTV system with a DISH satellite receiver 
that was been working fine for many months. But I couldn't leave it well 
enough alone, and in the process of fixing something that probably 
wasn't even broke to begin with (and that I can no loner even remember) 
I broke my IR Blaster config.


Gentoo running kernel 2.6.13-gentoo-r5

Running udev

IR blaster from http://www.irblaster.info

Lirc config to drive it based on the instructions at 

JVC_RAW command set in /etc/ledxmit.conf

Module options look like this:
     alias char-major-72 ledxmit_serial
     below ledxmit_serial ledxmit_dev
     pre-install ledxmit_serial /bin/setserial /dev/ttyS0 uart none
     options ledxmit_serial irq=4 io=0x3f8

I have been using lirc 0.72 to build the ledxmit stuff, and now I'm 
trying 0.8.0. I'd be happy getting either to work.

Everything makes and installs fine, but I run into the following problems:

1. It seems to want /dev/ledxmit, but I only have /dev/ledxmitd and 
/dev/ledxmit0 (which is the 72,0 device). I suppose this is because I'm 
running udev. Fine, I made a symlink called 'ledxmit' that points to 
ledxmit0 and that problem goes away. Is that correct? I end up with this:
    lrwxrwxrwx  1 root root     8 Mar  6 08:11 ledxmit -> ledxmit0
    crw-rw----  1 root root 72, 0 Mar  6 08:10 ledxmit0
    srw-rw-rw-  1 root root     0 Mar  6 08:09 ledxmitd

2. When I run my channel change script (which calls ledxmit-irsend) I 
get the following errors (example is trying to change to channel 3):
     Mar  6 07:31:48 mythtv ledxmitd: accepted new client on /dev/ledxmitd
     Mar  6 07:31:48 mythtv ledxmitd: too short gap: 100000
     Mar  6 07:31:48 mythtv ledxmitd: error processing command: 
     Mar  6 07:31:48 mythtv ledxmitd: transmission failed
     Mar  6 07:31:48 mythtv ledxmitd: removed client

Any ideas on what I might have done to kill it? I've re-installed it 
several times and tried several different options, but nothing seems to 
make a difference.


More information about the mythtv-users mailing list