[mythtv-users] LVM problem upgrading to FC5

Mark list at onnow.net
Sun Jun 25 14:31:26 UTC 2006

I doubt that you have actually deleted any data.  If the partitions are still there, it will just be a matter of fixing the LVM.  I am not sure, but FC3 may have been LVM v.1 and FC5 is v.2
Do a google search for lvm 1 to 2 upgrade.  Also, it is possible to re-form your LVM through manual commands. No guarantee on getting the data back, but it should be do-able.

  ----- Original Message ----- 
  From: Argus Array 
  To: mythtv-users at mythtv.org 
  Sent: Sunday, June 25, 2006 12:08 AM
  Subject: [mythtv-users] LVM problem upgrading to FC5

  Hi everyone,

  I realize this is only tangentially related to mythtv, but I haven't gotten any help from the linux-lvm list which seems pretty quiet.

  I have been using LVM for several months to record mythtv files across a 200GB and 160GB disk (hdb and hdc). 

  Recently I decided to upgrade my FC3 install to FC5.  After the install, my LVM mount does not come up.  It appeared that all of the LVM information in /dev/ was gone; however, only the non-LVM drive (/dev/hda) should have been touched by the FC5 upgrade. 

  This is my fstab entry:
  /dev/VGforMythTV/video  /var/media              xfs     defaults        1 1

  This is what fdisk shows:
  /dev/hdb1               1       24792   199141708+  8e  Linux LVM

  /dev/hdc1               1       19929   160079661   8e  Linux LVM 

  In my attempt to fix this, I think I may have totally fouled things up; I tried to create a new volume group with the same name and more PVs for the new drives, then combine them together into an PV with the old LV name.  However, this still does not allow it to mount.  

  Any ideas?  Have I deleted all my data?

  Thanks for any help,


  I've pasted my history commands below.

    552  /usr/sbin/pvcreate /dev/hdb1 
    553  /usr/sbin/pvcreate /dev/hdc1
    554  /usr/sbin/vgcreate VGforMythTV /dev/hdb1 /dev/hdc1
    555  mount /dev/VGforMythTV /var/media
    556  mount /dev/VGforMythTV/video /var/media 
    558  lvcreate --name video VGforMythTV
    559  /usr/sbin/lvcreate --name video VGforMythTV
    560  /usr/sbin/lvcreate --name video -l VGforMythTV
    561  /usr/sbin/lvcreate --name video -l ` VGforMythTV 
    562  /usr/sbin/lvcreate --name video -l 1 VGforMythTV
    563  mount /dev/VGforMythTV/media /var/media
    564  mount /dev/VGforMythTV/video /var/media
    565  mount -t xfs /dev/VGforMythTV/video /var/media
    566  mount /dev/VGforMythTV/video /var/media 
    567  /usr/sbin/lvcreate --name video -l 2 VGforMythTV
    568  ls
    569  /usr/sbin/pvdisplay 
    570  /usr/sbin/lvmdiskscan 
    571  mount /dev/VGforMythTV /var/media/
    572  mount /dev/VGforMythTV/video /var/media/ 
    573  mount /dev/VGforMythTV/media /var/media/
    574  mount /dev/VGforMythTV/video /var/media/

  (none of these last commands worked -- there is no sign of the original data, but I have now created the VGforMythTV volume group but it only shows my two new logical volumes, but not the original one with all my data).  


  mythtv-users mailing list
  mythtv-users at mythtv.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060625/89aa8c88/attachment.htm 

More information about the mythtv-users mailing list