[mythtv-users] spdif:alsa does not work

Gregg 3gemail at gmail.com
Sat Jun 24 16:46:42 UTC 2006

>>As spdif exists as a name, this made me think whether your asound.conf
>>was set up correctly. Checking your output further down:

> analog-hw {
>     type hw
>     card 0
> }
> digital-hw {
>     type hw
>     card 0
>     device 0

>>This tells me that you have configured you analog and digital sound
>>using the same device -  the first device on the soundcard, which is
>>likely wrong as typically the default device (0,0) is for analog

>>If you run 'aplay -l' it will tell you which device number you need to
>>use for your digital sound definition - look for IEC958 playback if
>>the soundcard has more than one digital device (i.e. some may have
>>digital input support.)

>>For example, if I run 'aplay' I get the following information for my SPDIF:

>>card 0: CK8S [NVidia CK8S], device 2: Intel ICH - IEC958 [NVidia
CK8S - >>IEC958]

>>Using this info I then amend asound.conf to read:

>>digital-hw {
>>type hw
        >>card 0
        >>device 2

>>which tells ALSA to use device 2 for digital output.

>>I'm pretty sure this is what's stopping you. Try this and let us know
>>if digital sound is working again.


I ran aplay -l | grep card and got this:
card 0: Live [SBLive! Value [CT4780]], device 0: emu10k1 [ADC
Capture/Standard PCM Playback]
card 0: Live [SBLive! Value [CT4780]], device 2: emu10k1 efx
[Multichannel Capture/PT Playback]
card 0: Live [SBLive! Value [CT4780]], device 3: emu10k1 [Multichannel Playback]

I tried all devices.  device 2 and 3 gave me no sound at all with
ALSA:spdif,  Device 0 gave me sound, but only static with hdtv and
surround.  any other suggestions??


More information about the mythtv-users mailing list