[mythtv-users] Optical or coax digital out on nforce3 cks8 sound

Nick knowledgejunkie at gmail.com
Fri Jun 23 18:23:53 UTC 2006

On 23/06/06, Stephen Hocking <stephen.hocking at gmail.com> wrote:
> Just struggling with the sound out on a new motherboard, an Nforce3
>    chipset with the cks8 sound chip. The asoundrc that worked a treat
>    with the nforce2 that I had doesn't on this. The red glow doesn't
>    appear at the end of the optical cable, and I can't get anything out
>    of the coaxial SPDIF output either. Very frustrating. Has anyone else
>    got this working?
>    aplay -l output....
>    sh-3.1$ aplay -l
>    **** List of PLAYBACK Hardware Devices ****
>    card 0: CK8S [NVidia CK8S], device 0: Intel ICH [NVidia CK8S]
>      Subdevices: 1/1
>      Subdevice #0: subdevice #0
>    card 0: CK8S [NVidia CK8S], device 2: Intel ICH - IEC958 [NVidia
> CK8S - IEC958]
>      Subdevices: 0/1
>      Subdevice #0: subdevice #0

I'm using an nForce3 Ultra board with optical SPDIF (NVidia CK8S) with
no problems at all, using the digital-sound asound.conf from the wiki.

The important thing to check (apart from that the SPDIF is correctly
connected to your motherboard if on a backplate) is that your
asound.conf file is setup to use the correct device for SPDIF. From
mine I have the following, which matches my aplay -l output for the
SPDIF device:

pcm.digital-hw {
 type hw
 card 0
 device 2

That was all I needed to do. I just worked after that by passing
ALSA:spdif to MythTV having set ALSA:dmix-digital as my default in

In alsamixer, I have the IEC958 device enabled, IEC958 Playback at
100%, and IEC958 playback source set to PCM.


MythTV Official wiki:
MythTV users list archive:

More information about the mythtv-users mailing list