[mythtv-users] AC3 passthrough

Landon Clark landon.clark at wnsgs.com
Tue Jun 13 18:44:53 UTC 2006

Hi Mike,
Thanks for the suggestion.  Tried that and got the same response.  Finally
got it to work by setting the passthrough device to be dmix.  I am not sure
if that is good or bad, but it works so I am going with it!

Thanks for the help,

On 6/12/06 10:24 AM, "Michael T. Dean" <mtdean at thirdcontact.com> wrote:

> On 06/12/2006 01:12 PM, ldc online wrote:
>> > I am trying to get ac3 pass thru to to work on my new mythtv box that
>> > I setup over the weekend. In the setup screens, I enabled AC3 pass
>> > through, but when I watch a DVD straight from a disc, I only get two
>> > channel.  I have also tried using XINE instread of mplayer, but when I
>> > set that speaker arrangment settings to pass through and
>> > restart xine, I get an Audio Device is Unavailable error.  Clicking on
>> > more in XINE, I
>> > see the following possibly relevant messages:
>> > Audio_decoder: error: unknown buffer type: 01060000
>> > Audio_decoder: error: unknown buffer type: 04000000
>> > Audio_decoder: error: unknown buffer type: 02990000
> What do you have specified for the audio.device.alsa_passthrough_device
> in ~/.xine/config?
> # device used for 5.1-channel output
> # string, default: iec958:AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2
> #audio.device.alsa_passthrough_device:iec958:AES0=0x6,AES1=0x82,AES2=0x0,AES3> 0x2
> If the same as the above (or with the bottom line uncommented), try just
> plain "iec958" instead.
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060613/f097fb8e/attachment.htm 

More information about the mythtv-users mailing list