[mythtv-users] Help getting my mythtv box connected to my Sony TV

Joshua Caskey ummgewd at yahoo.com
Sun Jun 11 01:34:38 UTC 2006

Hi everyone. I am trying desperately to get a high definition mythtv box up and running.  Please be understanding as I have tried to look everywhere for an answer to this issue and have not been able find an answer.
I have managed to get everything going except my connection to my TV.  I have a Sony GWIV  or KDF-60WF655 tv.  I got a bunch of powerstrip timings off of the avsforum site for my TV.  When I first put "IgnoreEDID" "1" I was getting a 720x480 resolution.  I realized after looking at my Xorg.0.log file that that option was deprecated and I changed the line to "UseEDID" "FALSE" which caused instead of the low resolution a blank screen.  I tried most of the resolutions in my Xorg file below and none work.  All result in a blank screen.  I know the connection is okay since I can get the desktop on my TV before I fixed the UseEDID problem.  I have a NVIDIA FX5200 generic video card with 128MB of ram.  The card is hooked to the TV via a DVI to HDMI cable.  My video driver is version 8756 which I got from the yum atrpms.net server.
I am hoping someone reading this mail list has a GWIII or GWIV Sony TV and can give me some pointers.  I have read all over the internet and cannot seem to figure this one out.  Thanks in advance for your help.  (Please give instructions if you need more info since I am new to linux.)
I have not gone into the service manual on my tv if that matters. I am using the 8756 nvidia driver.
Here is the necessary sections of my xorg.conf file:  (Three items I guessed on are HorizSync, VertRefresh, and the +hsync and +vsync.  Can you give me more info on this because the powerstrip timings I found do not let me know how to set these items).
Section "Monitor"
Identifier "Sony60"
VendorName "Sony"
ModelName "KDF60"
Option "UseEDID" "FALSE"
DisplaySize 320 180
HorizSync 30.0 - 90.0
VertRefresh 20.0 - 150.0
ModeLine "720x480" 27.000 720 736 798 858 480 489 495 525 +hsync +vsync
ModeLine "800x600" 58.712 800 1048 1072 1304 600 640 642 753 +hsync +vsync
ModeLine "1280x720" 75.600 1280 1360 1400 1648 720 738 757 787 +hsync +vsync
ModeLine "1280x768" 79.740 1280 1360 1496 1736 768 769 781 787 +hsync +vsync
ModeLine "1304x734" 74.250 1304 1336 1376 1648 734 745 750 773 +hsync +vsync
ModeLine "1312x744" 79.096 1312 1376 1512 1728 744 745 748 774 +hsync +vsync
ModeLine "1320x744" 78.140 1320 1384 1520 1720 734 758 763 784 +hsync +vsync
ModeLine "1344x734" 78.923 1344 1512 1560 1720 734 758 763 784 +hsync +vsync
ModeLine "1376x768" 86.946 1376 1440 1576 1912 768 777 780 780 +hsync +vsync
ModeLine "1384x768" 84.203 1384 1512 1656 1872 768 768 771 771 +hsync +vsync
ModeLine "1384x784" 85.421 1384 1456 1600 1816 784 785 788 811 +hsync +vsync
ModeLine "640x480" 26.730 640 690 746 792 480 518 548 562 +hsync +vsync interlace
ModeLine "1920x1080" 82.350 1920 2089 2145 2440 1080 1082 1087 1125 +hsync +vsync 
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "ConnectedMonitor" "DFP"
Option "NoLogo" "1"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
Option "ConnectedMonitor" "DFP"
Option "NoLogo" "1"
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Sony60"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x720"
Section "DRI"
Group 0
Mode 0666
Here is the output from my xorg.0.log file if I comment out the UseEDID line.  (Let me know if you need more info.)
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5200 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): VideoBIOS:
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0):     Sony TV (DFP-0)
(--) NVIDIA(0): Sony TV (DFP-0): 135 MHz maximum pixel clock
(--) NVIDIA(0): Sony TV (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1320x744"; removing.
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 720 x 480
(WW) NVIDIA(0): No size information available in DFP-0's EDID; cannot compute
(WW) NVIDIA(0):     DPI from EDID.
(**) NVIDIA(0): DPI set to (57, 67); computed from "DisplaySize" Monitor section option
(--) Depth 24 pixmap format is 32 bpp

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060610/f70dbe66/attachment.htm 

More information about the mythtv-users mailing list