[mythtv-users] Almost upgraded to 0.19; tuner and channel listing problems remain

James Pifer jep at obrien-pifer.com
Thu Jun 8 02:27:16 UTC 2006

On Wed, 2006-06-07 at 20:14 -0400, Michael T. Dean wrote:
> On 06/07/2006 07:13 PM, Nick wrote:
> >On 08/06/06, James Pifer <jep at obrien-pifer.com> wrote:
> >  
> >
> >>I've upgraded to fc5 and mythtv 0.19. I have a couple problems yet to be
> >>worked out. LiveTV seems to work ok, but recordings do not. Somewhere
> >>it's still looking for Tuner 0 even though I've changed to Tuner 1 in
> >>mythtvsetup wherever I can find it. Any suggestions? (PVR350 and PVR250)
> >>
> >>My listings are also screwed up. I had found something earlier today
> >>googling about the exact same problem, but now I can't find it. A lot of
> >>my channels now say NO DATA. For the ones that do have data they are a
> >>channel off, meaning what's listed as channel 4 is really channel 5. Is
> >>there a quick fix for this? Should I blow away channel data and re-
> >>download it? (if so, how?) I use labs.zip2it.com for my channel data.
> >>    
> >>
> >I would use mythtv-setup to remove and re-add your capture cards, and
> >also remove your old listings and then re-add those. The ivtv drivers
> >made changes to the tuner names a while back which could still be
> >persisting in your database, and the best way to ensure that the old
> >data is removed and the cards are setup correctly is to remove them
> >and then re-add them. Don't forget to ensure that you connect your
> >video sources to the correct card inputs in the mythtv-setup program
> >having reconfigured your cards and listings.
> >
> Use the "Delete All" button to get rid of your capture cards.  That way, 
> you'll restart the card numbering.
> Mike

No go. I removed and re-added my capture cards and my channel source and
channels. Ran mythfilldatabase and my listing in mythweb is still
screwed up. The first few channels almost look jumbled together as well
as missing data. The latter channels just look to be still one off. 

Is there an order I should take like?:
Remove capture cards and TV source and exit mythtvsetup
Run mythtvsetup and re-add capture cards
Re-add channel source
Assign to Input Connections
Exit and run mythfilldatabase

That was off the top of my head but does that sound right?


More information about the mythtv-users mailing list