[mythtv-users] (To Jeff Simpson) XV on PVR-350, Gentoo and MythTV wiki

Jeff Simpson jeffsimpson at alum.wpi.edu
Wed Jun 7 17:43:45 UTC 2006

On 6/7/06, Daniel Savard <daniel.savard at gmail.com> wrote:
> I followed instructions on the MythTV wiki
> http://www.mythtv.org/wiki/index.php/XV_on_PVR-350 for the
> Gentoo and X.Org 6.9/7.0 and ran into a problem with source code and the
> .ebuild file. Since this section is from Jeff Simpson, I guess he is the guy
> to whom this post is for.
>  First, in the
> http://www.mit.edu/~je18337/ivtvdev/xf86-video-ivtvdev-0.10.6.ebuild
> file, there is extra lines at the end with the ^M character which confuse
> Gentoo emerge.

Huh, that's strange. Must have been from where I hosted it or
something, I just copied the file out of my own local overlay and
uploaded it. I'll have to check it again to see if it has issues here.

>  Second, after removing these extra lines, the compilation is ending with
> the following errors:
>   i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DXFree86Server
> -DIN_MODULE -DXFree86Module -DXFree86LOADER -I/usr/include/xorg -O2
> -march=pentium3 -fomit-frame-pointer -pipe -MT ivtv_xv.lo -MD -MP -MF
> .deps/ivtv_xv.Tpo -c ivtv_xv.c  -fPIC -DPIC -o .libs/ivtv_xv.o
>  ivtv_xv.c: In function `IVTVSetupImageVideoOverlay':
>  ivtv_xv.c:322: warning: assignment from incompatible pointer type
>  ivtv_xv.c: In function `IVTVStopVideo':
>  ivtv_xv.c:466: error: `errno' undeclared (first use in this function)
>  ivtv_xv.c:466: error: (Each undeclared identifier is reported only once
>  ivtv_xv.c:466: error: for each function it appears in.)
>  ivtv_xv.c: In function `IVTVPutImage':
>  ivtv_xv.c:707: error: `O_RDWR' undeclared (first use in this function)
>  ivtv_xv.c:708: error: `errno' undeclared (first use in this function)
>  ivtv_xv.c:708: error: `ENODEV' undeclared (first use in this function)
>  make[2]: *** [ivtv_xv.lo] Error 1
>  make[2]: Leaving directory
> `/var/tmp/portage/xf86-video-ivtvdev-0.10.6/work/xf86-video-ivtvdev-0.10.6/src'
>  make[1]: *** [all-recursive] Error 1
>  make[1]: Leaving directory
> `/var/tmp/portage/xf86-video-ivtvdev-0.10.6/work/xf86-video-ivtvdev-0.10.6'
>  make: *** [all] Error 2
>  !!! ERROR: x11-drivers/xf86-video-ivtvdev-0.10.6 failed.
>  Call stack:
>    ebuild.sh, line 1539:   Called dyn_compile
>    ebuild.sh, line 939:   Called src_compile
>    ebuild.sh, line 1248:   Called x-modular_src_compile
>    x-modular.eclass, line 317:   Called x-modular_src_make
>    x-modular.eclass, line 312:   Called die
>  !!! emake failed
>  !!! If you need support, post the topmost build error, and the call stack
> if relevant.
>  So, I guess at least one header file is missing in the source header. Is it
> possible to correct the source accordingly?

I should start by saying that the ebuild is mostly a collection of
patches combined with the ebuild from the fbdev driver package. If
something changed recently in xorg I might need to make those changes
in the driver package.

Do you know what headers are missing, by any chance?

Also, what version of xorg do you have installed and what do you have
in your make.conf file about video drivers? I don't know if it's
required or not, but I can compare it to what I have to see if it

 - Jeff

More information about the mythtv-users mailing list