[mythtv-users] gentoo, mythburn, mjpegtools 1.8.0 failure

Jesse Guardiani jesse at guardiani.us
Sun Jun 4 21:11:36 UTC 2006

On Sunday 04 June 2006 4:58 pm, Jesse Guardiani wrote:
> Hello,
> I'm trying to get mythburn cvs working on gentoo with 0.19. I can
> get older versions of mjpegtools to work, but the resulting DVDs 
> crash Xine/mplayer/whatever. So I'm trying to get mjpegtools 1.8.0-r1 
> to work since others have reported success with it in other distros. 
> Unfortunately, it's segfaulting on me (2.93ghz Celeron D CPU):
> # jpeg2yuv -v 0 -n 60 -I p -f 29.97 -j /usr/share/mythburn/temp.bsd/output1.png.jpg
> YUV4MPEG2 W720 H480 F30000:1001 Ip A1:1 C420jpeg
> Segmentation fault
> Exit 139
> I've tried turning off mmx (hacked the ebuild since disabling the use
> flag had no effect), but that didn't help.
> Has anyone else experienced this? Is there a solution?
> Thanks!

Arg. nm. found the solution after reading this:

Patch for jpeg-mmx ebuild is here:

Rebuilt jpeg-mmx and mjpegtools and now it works. Sorry for the noise.

Jesse Guardiani
Programmer/Sys Admin
jesse at guardiani.us

More information about the mythtv-users mailing list