[mythtv-users] So close, but not quite - a 1080i modeline for my HDTV CRT

Matt Mossholder matt at mossholder.com
Sat Jun 3 21:46:22 UTC 2006

On Sat, 2006-06-03 at 16:19 -0400, Sasha Z wrote:
> I tried both that ATSC modeline and the doubled modeline, and the CRT
> refused to sync to them. I just got a black screen. Is there some way
> to use that EDID produced modeline while forcing the bounding box
> bigger?
> Thanks!
> --Sasha

If you add the options I specified in my first post, you shouldn't have
any issues with the bounding box. 

Here's what I have, specific to nVIDIA and the display in my
configuration (take note that I am NOT defining the modelines, the
nVIDIA driver creates them based on the EDID info):

Section "Device"
	Identifier      "Generic Video Card"
	Driver "nvidia"
	Option "RenderAccel"           "1"
	Option "NoLogo"                "1"
	Option "UseEdidFreqs"          "true"
	Option "UseEDID"               "true"
	Option "RandRRotation"         "1"
	Option "HWCursor"              "0"
	Option "ModeValidation"        "NoVertRefreshCheck"
	Option "UseEdidDpi"            "FALSE"
	Option "ConnectedMonitor"      "DFP"  # I'm using a CRT over DVI
	Option "UseDisplayDevice"      "DFP"  # I'm using a CRT over DVI
Screen  0

Section "Monitor"
	Identifier      "Generic Monitor"
	DisplaySize     487 274 # to specify 100dpi @ 1080i

Section "Screen"
        Identifier      "Default Screen"
        Device          "Generic Video Card"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Viewport        0 0
                Depth           24
                Modes           "1920x1080_120i" "720x480_60"
"720x480_60i" "640x480_60"

More information about the mythtv-users mailing list