[mythtv-users] No "Line In" Capture in 0.19; Sound works in Music/Videos

reclusive monkey reclusive.monkey at gmail.com
Thu Feb 23 12:24:36 UTC 2006

Hello Everyone,

I posted this on the MthTVTalk forums but don't seem to be getting any
response, so I though I would try posting here. I notice I am not the
only person with this problem, and I have read through the docs, the
forum, the wiki and everything else I can find. I've also tried
changing every parameter one at a time but still no luck.

I previously had a perfectly working 0.18.1 version of MythTV on
Slackware 9.1. I have had the week off for my Birthday, so I thought I
would treat myself by updating to the new 0.19 (great timing guys ;-),
and updating to Slackware 10.2. I was going to write a HOWTO as well,
as it only took me around six hours or so for the whole process, but
this showstopper put paid to all that. Anyway, here is the info;

Slackware 10.2
Kernel 2.6.13 (from Slackware's "testing" repository)
MythTV 0.19
alsa-driver-1.0.9b_2.6.13 (from Slackware's "testing" repository)
alsa-lib-1.0.9 (stock Slackware package)
alsa-oss-1.0.9 (stock Slackware package)
alsa-utils-1.0.9a (stock Slackware package)
lame3.96.1 (from lame website)

So, I installed Slackware, upgraded the kernel, installed the new
kernel alsa-drivers, ran alsaconf and set the mixer levels. Installed
TVTime, checked all was working with my TV card (Philips
Semiconductors SAA7130) and the sound works fine using Ensoniq 5880
Audio PCI. So went on and installed mythtv 0.19 plus plugins, no
problems. Set things up with mythtv-setup, started mythbackend, ran
mythfilldatabase and ran mythfrontend. First snag; no sound on "Watch
TV". So I tried a recording, still no sound. Tried Videos, sound works
fine (most of my videos use AC3). Tried Music with MP3's; sound fine.
So I swapped the sound card with a Sound Blaster Live I have in my
main PC, ran alsaconf again, still no luck.

I have tried changing all the sound settings one by one, closing
mythbackend first, then running mythtv-setup, mythbackend,
mythfilldatabase, then mythfrontend, no luck. Enable AC3 to SPDIF
passthrough is NOT checked. Alsamixer and Rexima both confirm that
Line In is to be captured, mythtv is in the "audio" users group, and
all /dev/sound devices belong to the audio group. I've not been able
to make video/music sound _NOT_ work at all, but nothing works for the
TV Card sound capture. I would really appreciate some help here, I am
totally at a loss. The previous install of 0.18.1 worked no problem,
so I can't see it being tha hardware (I had to use rexima to get the
"IGain" volume up, but once that was done it was fine). However I can
easily put in the Sound Blaster Live to test with a better
known/supported card. If there is any more info required (or anything
I have left out) please let me know.

I know its not much, but once I can get the sound working I will be
more than happy to write up a full HOWTO on installing on Slackware
10.2 (a fantastically stable system, not many steps required to get a
working Myth system).

Yours Hopefully,


This email wasn't from me. I didn't send it to you. You can't prove anything!

More information about the mythtv-users mailing list