[mythtv-users] problems with tvtoday grabber and mythfilldatabase --manual

David Watkins watkinshome at gmail.com
Mon Feb 20 16:56:21 UTC 2006

On 20/02/06, lau.ent at gmx.ch <lau.ent at gmx.ch> wrote:
> Hi
> I'm new to mythtv and installed everything as per howto on my suse linux
> 10.0 with WinPVR 350. MythTV v0.19.
> I'm now having problem configuring the video sources. As I live in
> Switzerland I selected the grabber for Germany (tvtoday) and channel
> frequency table for europe-west. When I click 'next' on the screen I got the
> follwing message:
> "You MUST run 'mythfilldatabase --manual the first time. Instead of just
> 'mythfilldatabase'. Your grabber does not provide channel numbers, so you
> have to set them manually."

Well if your grabber doesn't provide channel numbers you'll have to
enter them into the frequency field of the channel setup screen in
mythtv.  Not sure how you'd find out what they need to be though.  In
the UK you can generally look up the channel numbers for the local
transmitter for OTA.  I've never used cable but I assume cable
providers also provide this information.  If you can put your card in
a windows box then the provided software will do a scan and find the
channel numbers for you.

In the UK I ran the radio times grabber with the --configure option,
which let me pick the channels I wanted and created a config file
containing a list of xmltv ids.  I entered the appropriate xmltv id
into the mythtv channel editor too.

Now I run the grabber and mythfilldatabase with the --file option. 
The grabber first, to create the xmltv file, then mythfilldatabase to
read the file in.  I've never bothered to try and combine the
operation into a single mythfilldatabase command, though I assume it
can be done.

Not sure that this will help you in Switzerland, but it might - Good Luck.

More information about the mythtv-users mailing list