[mythtv-users] Compile problems on x86_64

Axel Thimm Axel.Thimm at ATrpms.net
Sat Feb 11 15:55:46 UTC 2006

On Sat, Feb 11, 2006 at 12:22:38PM +0000, Graeme Hilton wrote:
> I'm trying to compile the latest SVN (8922) and I get the following error:
> /usr/bin/ld: /usr/X11R6/lib64/libGL.a(glapi.o): relocation R_X86_64_32
> against `a local symbol' can not be used when making a shared object;
> recompile with -fPIC
> /usr/X11R6/lib64/libGL.a: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> I've tried running the command with the suggested -fPIC flag, but this
> has no effect.
> I've recently changed a lot on my system by removing all the i386
> packages so I can have a pure 64bit system.  In an effort to resolve the
>  above issue I've reinstalled the xorg i386 packages, but the compile
> error still occurs.
> Has anyone else had this issue?

What system is that? The error message may be suggestion that
/usr/X11R6/lib64/libGL.a needs to be rebuilt, so maybe you'd have to
bother your vendor on rebuilding it with -fPIC.

I just finshed building mythtv svn on several RHEL, FC and RHL
distros, so at leats with updated systems these distros should be OK.
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20060211/05abe6d9/attachment.pgp

More information about the mythtv-users mailing list