[mythtv-users] ALSA not working in Myth

Chris Lynch lynchseattle at gmail.com
Sun Feb 5 05:16:05 UTC 2006

Hello all,

So today I decided to break down and move to the SVN version of Myth
(8858).  I have everything working now with the exception of audio.
Previously ALSA worked just fine from RPMs (I'm running on FC4), but now I
get nothing from the frontend.  When I compiled myth, I did the following
./configure --prefix=/usr --enable-xvmc --enable-opengl-vsync
--enable-proc-opt --enable-audio-alsa --enable-firewire --enable-dts

That should enable ALSA... and I get no compile errors and all looks good.

But when I run Myth and play any file, I get the following in the log:
2006-02-04 20:51:17.917 Audio output device is set to an ALSA device but
ALSA support is not compiled in!
2006-02-04 20:51:17.917 NVP: Disabling Audio, reason is: Unable to create

This is really confusing - if I play a file in Xine or with mplayer using
ALSA, it plays just fine.  Yikes.

Any ideas?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060204/64b5e885/attachment.htm

More information about the mythtv-users mailing list