[mythtv-users] tv_grab_za and mythtv-setup

Mattias Holmlund mattias.holmlund at gmail.com
Sun Dec 31 13:25:53 UTC 2006

On 12/31/06, Dave Jones <squilla.dave at gmail.com> wrote:
> Hi all.
> First post/question.
> When running mythtv-setup tv_grab_za is not an available choice for
> input source, even though it's on my system (and it works if run from
> a terminal).
> How/where do I link it or move it so that mythtv-setup can use it?

The current version of MythTV has a hard-coded list of available
grabbers (SVN detects them automatically). There are two ways of
adding tv_grab_za:

1. Edit the source and recompile.
2. Create a symlink so that tv_grab_za is called when MythTV tries to
call another grabber.

The second solution is a bit of a hack, but it works. Just find a
grabber that MythTV supports (such as tv_grab_uk_rt), rename it and
create a symbolic link so that whenever Myth tries to run
tv_grab_uk_rt, it actually runs tv_grab_za.

With that said, tv_grab_za needs some attention. I run nightly tests
of all xmltv-grabbers, and tv_grab_za doesn't follow all the new
requirements for xmltv-grabbers. See


Among other things, it doesn't include a timezone in the output. It
will probably work in MythTV anyway since myth has a reasonable
fallback, but if you get timezone problems, start by blaming
tv_grab_za and not MythTV. If you or anyone else want to improve
tv_grab_za, head on over to www.xmltv.org and join the xmltv-devel


Mattias Holmlund

More information about the mythtv-users mailing list