[mythtv-users] semi-OT: HD-3000: cx8802_timeout whenever I try to use ATSC

James Colannino james at colannino.org
Fri Dec 29 06:38:42 UTC 2006

I apologize if this is too general for the MythTV list in particular,
but it is related to my trying to setup a MythTV installation, and I'm
hoping that there are some seasoned HD-3000 users who could help me out.
 This card used to work just fine for me when I used to use the old V4L2
interface, but I haven't used the card in a while, and after finally
installing it again, I've had to use the newer DVB interface built into
the kernel.

I've been scouring the forums and google trying to find a solution to
this, and while I've seen many people with the timeout, I've not found a
solution that works for me. I've tried both kernel and, and neither of them work for me. Note that the dmesg outputs
listed below are for the kernel.

As a heads up, if it means anything to anybody, I'm using a dual core
Athlon 64 with an Asus A8V Deluxe motherboard.

I'm using the DVB drivers built into the kernel. I have the necessary
firmware in /lib/firmware, and dmesg has confirmed for me that the
firmware is being loaded successfully. Every time I try to use dtvsignal
or dtvscan however, I get the following dumped to dmesg:

cx88[0]/2: cx8802_timeout
cx88[0]/2: cx8802_stop_dma
cx88[0]/2: restarting queue
cx88[0]/2: cx8802_restart_queue
cx88[0]/2: cx8802_restart_queue: queue is empty

I have confirmed that the antenna is giving me a signal, because NTSC
works just fine. I have no idea what the problem is, and I'm really
getting frustrated :( Does anybody have any ideas as to where I can go
from here?

Just for reference, here's every dmesg line relevant to the HD-3000 from
initialization of the module to the timeout. And, for what it's worth,
I'm using ivtv 0.7.3, if that makes any difference (I'll also show my
ivtv output, just in case it's relevant for whatever reason.)

HD-3000 dmesg output:

cx2388x dvb driver version 0.0.5 loaded
CORE cx88[0]: subsystem: 7063:3000, board: pcHDTV HD3000 HDTV
TV tuner 60 at 0x1fe, Radio tuner -1 at 0x1fe
tuner 1-0061: chip found @ 0xc2 (cx88[0])
tuner 1-0061: type set to 60 (Thomson DTT 761X (ATSC/NTSC))
tda9887 1-0043: chip found @ 0x86 (cx88[0])
GSI 20 sharing vector 0xC9 and IRQ 20
ACPI: PCI Interrupt 0000:00:0d.2[A] -> GSI 18 (level, low) -> IRQ 20
cx88[0]/2: found at 0000:00:0d.2, rev: 5, irq: 20, latency: 64, mmio:
cx88[0]/2: cx2388x based dvb card
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 0 (Oren OR51132 VSB/QAM Frontend)...
cx2388x v4l2 driver version 0.0.5 loaded
ACPI: PCI Interrupt 0000:00:0d.0[A] -> GSI 18 (level, low) -> IRQ 20
cx88[0]/0: found at 0000:00:0d.0, rev: 5, irq: 20, latency: 64, mmio:
cx88[0]/0: registered device video1 [v4l2]
cx88[0]/0: registered device vbi1
cx88[0]/0: registered device radio1
or51132: Waiting for firmware upload(dvb-fe-or51132-vsb.fw)...
or51132: Version: 10001134-19430000 (113-4-194-3)
or51132: Firmware upload complete.
cx88[0]/2: queue is empty - first active
cx88[0]/2: cx8802_start_dma w: 0, h: 0, f: 2
cx88[0]/2: setting the interrupt mask
cx88[0]/2: [ffff81003b25f200/0] cx8802_buf_queue - first active
cx88[0]/2: cx8802_timeout
cx88[0]/2: cx8802_stop_dma
cx88[0]/2: restarting queue
cx88[0]/2: cx8802_restart_queue
cx88[0]/2: cx8802_restart_queue: queue is empty

Haupauge PVR-350 output:

Linux video capture interface: v1.00
ivtv:  ==================== START INIT IVTV ====================
ivtv:  version 0.7.3 (tagged release) loading
ivtv:  Linux version: SMP preempt mod_unload gcc-4.1
ivtv:  In case of problems please include the debug info between
ivtv:  the START INIT IVTV and END INIT IVTV lines, along with
ivtv:  any module options, when mailing the ivtv-users mailinglist.
ivtv0: Autodetected Hauppauge WinTV PVR-350 card (cx23415 based)
ACPI: PCI Interrupt 0000:00:0c.0[A] -> GSI 17 (level, low) -> IRQ 16
tveeprom 0-0050: Hauppauge model 48132, rev K168, serial# 2942383
tveeprom 0-0050: tuner model is LG TAPE H001F MK3 (idx 68, type 47)
tveeprom 0-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 0-0050: audio processor is MSP4448 (idx 27)
tveeprom 0-0050: decoder processor is SAA7115 (idx 19)
tveeprom 0-0050: has radio, has IR remote
tuner 0-0061: chip found @ 0xc2 (ivtv i2c driver #0)
tda9887 0-0043: chip found @ 0x86 (ivtv i2c driver #0)
saa7115 0-0021: saa7115 found @ 0x42 (ivtv i2c driver #0)
saa7127 0-0044: saa7127 found @ 0x88 (ivtv i2c driver #0)
msp3400 0-0040: MSP4448G-A2 found @ 0x80 (ivtv i2c driver #0)
msp3400 0-0040: MSP4448G-A2 supports radio, mode is autodetect and
ivtv0: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
ivtv0: loaded v4l-cx2341x-dec.fw firmware (262144 bytes)
ivtv0: Encoder revision: 0x02050032
ivtv0: Decoder revision: 0x02020023
ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)
ivtv0: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)
ivtv0: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)
ivtv0: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB
ivtv0: Create encoder radio stream
ivtv0: Allocate DMA decoder MPEG stream: 16 x 65536 buffers (1024KB total)
ivtv0: Allocate DMA decoder VBI stream: 512 x 2048 buffers (1024KB total)
ivtv0: Create decoder VOUT stream
ivtv0: Allocate DMA decoder YUV stream: 24 x 43200 buffers (1024KB total)
ivtv0: loaded v4l-cx2341x-init.mpg firmware (155648 bytes)
tuner 0-0061: type set to 47 (LG NTSC (TAPE series))
ivtv0: Initialized Hauppauge WinTV PVR-350, card #0
ivtv:  ====================  END INIT IVTV  ====================

Thanks very much in advance to all who read this! :)

My blog: http://www.crazydrclaw.com/
My homepage: http://james.colannino.org/

"Black holes are where God divided by zero." --Steven Wright

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 890 bytes
Desc: OpenPGP digital signature
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20061228/9ccc1dd6/attachment.pgp 

More information about the mythtv-users mailing list