[mythtv-users] Mono Audio does not work

Andrew Lyon andrew.lyon at gmail.com
Wed Dec 27 14:41:59 UTC 2006

On 12/26/06, Phill Edwards <philledwards at gmail.com> wrote:
> > I guess the ideal solution would be for myth to detect mono audio and
> > when encountered disable passthru and instead upsample the audio to 2
> > channels...
> Have a look at http://www.mythtv.org/wiki/index.php/Configuring_Digital_Sound
> and see if that helps.
> Regards.
> Phill
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

I have read that many times already, the problem is not that sound is
not working, it does work perfectly 99% of the time, I have all output
(tv and music etc) going to spdif, ac3 passthru works (on channels
that have ac3) and dts passthru also works  (dvds, hdtv etc), the
problem is that a small number of programmes have MONO audio, and
spdif output does not support mono!

The programme I have this problem with is scrapheap challenge, other
programmes on the same channel (discovery) have 2 channel audio and
they are fine.

I really dont know how to approach this problem, or even if it can be
fixed by changing my configuration, at the moment I dont have a
asound.conf at all, perhaps it is possible to setup one that converts
mono to 2 channel, and leaves everything else as it is ?

I am looking into a user job to change recorded programs to 2 channel
audio, that might do the job..


More information about the mythtv-users mailing list