[mythtv-users] Sound problems

Austin Roberts mythtv at ausiv.com
Mon Dec 25 19:29:11 UTC 2006

I was able to get MythTV to work with my sound card by reinstalling several
times. Then I got a Plextor external TV tuner, installed the drivers, and
now MythTV cannot capture audio from /dev/dsp. /dev/dsp1 (the Plextor card)
works fine.

I might also mention if I run

aplay /dev/dsp

I get:
aplay: playback:2021: read error

And if I run

aplay /dev/dsp1

While it is in use, I get
/dev/dsp1: Device or resource busy

I'm confident the device is not in use, because I get different messages
from devices in use, and I don't think it's a permission issue, because the
two devices have the same permissions, and /dev/dsp1 is usable.


> Sometimes the *sound* driver is been used by another process. Try "fuser
> /dev/dsp" to see who is using it and you can try to kill it.
>> Sounds like maybe a permission problem. Make sure your userid and
>> mythtv userid are added to the audio group 'sudo adduser <userid> audio'.

>> While you are in there, you might want to make sure you and mythtv are
>> part of the video group also. (check /etc/group and/or /etc/passwd).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20061225/721fd505/attachment.htm 

More information about the mythtv-users mailing list