[mythtv-users] mysql hates me... (still no luck)

clemens at dwf.com clemens at dwf.com
Sun Dec 24 07:00:59 UTC 2006

> > Database error was:
> > Access denied for user 'mythtv'@'MythTV.dwf.com' (using password: YES)
>  Your grant line didn't include the wildcard character % so you say the user mythtv had to come from ".dwf.com" and not "%.dwf.com".
Well, I would have never seen that,- I was so sure of what I typed.

But, since that iteration, 
    (a) I have typed the line in anew, no luck.
    (b) I have started over, no luck.
Im not sure what the correct way is to blow away the database, just in case 
is some bad data there, but I did remove the directory 
which doesnt have much in it...
    (c) and started over.
The host name has been variously MythTV and mythtv.  This hasnt confused 
anything else, but mabe mythtv... So I changed it to lower case everywhere and
rebooted.  Same problem.  Its probably time to stop working on this tonight,-
but here is the last typescript of the top of mythtv-startup.  Its still not 


[mythtv at mythtv ~]$ mythtv-setup
2006-12-23 23:48:17.603 Using runtime prefix = /usr/local
2006-12-23 23:48:17.607 DPMS is active.
2006-12-23 23:48:17.614 New DB connection, total: 1
2006-12-23 23:48:17.619 Unable to connect to database!
2006-12-23 23:48:17.619 Driver error was [1/1045]:
QMYSQL3: Unable to connect
Database error was:
Access denied for user 'mythtv'@'mythtv.dwf.com' (using password: YES)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open


any additional thoughts on what stupid things I must be doing would
be appreciated.

                                        reg at dwf.com

More information about the mythtv-users mailing list