[mythtv-users] Problem with mythconverg database

Robin Hill myth at robinhill.me.uk
Thu Dec 21 19:01:51 UTC 2006

On Thu Dec 21, 2006 at 05:29:48PM +0000, j.robert.buchanan at comcast.net wrote:
> When mythbackend is started during the boot process, the backend
> doesn't seem to open the mythconverg database.
> QMYSQL3: Unable to connect
> Database error was:
> Access denied for user 'mythtv'@'localhost' (using password: YES)
> However, if I start mythbackend by hand (not as a daemon) everything
> seems fine. How can I check to see if the mythbackend process, when
> started as a daemon, is giving the correct password for the
> mythconverg database? Can anyone see a different problem from the log
> segment?
No, that definitely looks like a password problem.  The likely reason
for this is that the mythbackend process is looking at a different
mysql.txt file when run as a daemon than when run manually.  Is it being
run under the same user account in both cases?  If not, then you'll need
to copy the ~/.mythtv/mysql.txt across (or symlink it).

    ( ' }     |       Robin Hill        <myth at robinhill.me.uk>  |
   / / )      | Little Jim says ....                            |
  // !!       |      "He fallen in de water !!"                 |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20061221/1ed0fc64/attachment.pgp 

More information about the mythtv-users mailing list