[mythtv-users] There's no guide data available

David Highley dhighley at highley-recommended.com
Thu Dec 21 06:39:18 UTC 2006

This is the second time I have run into this issue in building a mythtv
system from scratch. I'm running svn head, 12290, on a Fedora core 6
x86_64 system. I get the software all built and installed. Initialize
the database. Run mythv-setup and then run mythfilldatabase. I'm using
the datadirect zap2it channel guide. The backend status page shows:
Last mythfilldatabase run started on 2006-12-19 21:03 and ended on
2006-12-19 21:03.
Suggested next mythfilldatabase run: 2006-12-19 22:03.
There's no guide data available! Have you run mythfilldatabase?
DataDirect Status: Your subscription expires on 12/27/2006 11:16:59 PM

The /var/log/mythtv/mythbackend log file does not show the channels
being down loaded. It has two squawks:
2006-12-19 21:01:00.411 GetChannelData() failed because it could not
                        find channel number '3' in DB for source '1'.
QDateTime::fromString: Parameter out of range

If I run tv_grab_na_dd it does down load the channel information. The
last time I ran into this issue I ended up dumping the database from a
running system and loading it into the new system. I then deleted the
cards and entered new cards to match the hardware. I would really like
to figure out what causes this issue and how to correct it. I have
checked the archives, the mythtv.org documentation and of course
Googled. One last thing I noticed in comparing a working system with the
new installation. In the video sources page the Data Direct Lineup field
seems to be truncated in the system that works. That maybe a display
issue but I would not know how to check the database unless I dumped it
and looked at the ascii file.

More information about the mythtv-users mailing list