[mythtv-users] NFS woes

Tom Wright thomaswright at cantab.net
Thu Dec 7 09:30:24 UTC 2006

On Wednesday 06 December 2006 21:52, greg at nodecam.com wrote:
> I didn't do anything special with it - I just did mke2fs -j.  You might
> want to try -T largefile4, which I would have done if I'd had half a clue
> when I first set it up.

OK, I've tried ext3 exported over NFSv3 and it crashed again.  Just to check 
that it wasn't a disk fault, I tried this on the server:

cd [recordings directory]
cat * >/dev/null

...and it worked fine.

On Wednesday 06 December 2006 22:26, Tom Wright wrote:
> Hmm, I think NFSv4 is a bit experimental for me...thanks for the tip
> though, I'll have a go at that if ext3 still gives me gip.

After the above episode, I thought I'd give NFSv4 a go (a bit of a fuss to set 
up, isn't it?), and found that it crashed too.

On Thursday 07 December 2006 03:17, Aaron Blew wrote:
> Just to mention my experiences: I'm running an NFS root mythtv machine on
> top of XFS on top of LVM on top of Software RAID 5 on 3 250GB SATA drives.
> The server itself is a dual P-III 550 with 2GB of RAM and an Intel 100mbit
> NIC.  The client is a Athlon XP1800+ with 1GB of ram and an Intel 100mbit
> NIC and a Hauppauge PVR-150.  My NFS mount options are simple:
> nfsvers=3,tcp,rsize=32768,wsize=32768.

That's a similar setup to mine, though my NFS performance is always 
network-limited rather than CPU-limited (the server is a dual Athlon MP 
2200+, 2GB RAM and the client is an Intel Pentium-M 1.8GHz, 512MB RAM, both 
with gigabit NICs).

Anyway, the word for the day is "grrrr", and I'm pretty stuck on what to try 
next.  In summary:

Server filesystem: ext3, xfs or jfs (doesn't seem to make any difference apart 
from annoying me by taking ages to copy 30GB over to whatever I've just 
reformatted it as).
Large files read fine on server alone (cat to /dev/null)

Network filesystem: NFSv3
Server crashes on large file transfers

Network filesystem: NFSv4
Server crashes on large file transfers

I guess I'll try CIFS then, but I've got to find out how to get it to do posix 
file permissions.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20061207/897c022b/attachment.pgp 

More information about the mythtv-users mailing list