[mythtv-users] Sound problem with BT878 capture card

Lachek Butalek lachek at gmail.com
Tue Aug 29 15:57:34 UTC 2006

Tried alsamixer but it doesn't seem to have an F4 option. The
instructions I followed said to use Kmix and check the red button for
Line (which apparently selects it for recording) and uncheck the green
button for Line (which mutes it). As I mentioned, that didn't work.

I got some local assistance, however, and things are now working.
Apparently alsamixer lists a device called "Capture" which was not
toggled for recording. My assistor (<-word?) toggled the CAPTUR flag
for the Capture device, as well as for Line, cranked the volume on
Capture and decreased it for Line (leaving Line muted), and suddenly
everything works fine. I don't pretend to understand why or how. =)

My guess is  that this solution is functionally identical to the one
you proposed, so thank you very much for the assistance!

On 8/29/06, Chad <masterclc at gmail.com> wrote:
> On 8/29/06, Lachek Butalek <lachek at gmail.com> wrote:
> > A question which, I'm sure, has been asked a million times before but
> > which I could not find a solution to after hours of Googling. Please
> > be gentle.
> >
> > I have an analog BT878 capture card, a V-Stream VS-TV878RF more
> > commonly known as the KWorld BT878 tuner. It is card=78 in the BTTV
> > driver, and I'm also using tuner=2 which seems to work fine.
> >
> > The card has an analog audio passthru port, into which I have plugged
> > a stereo 1/8" audio patch cable that ends in my sound card (Ensoniq
> > AudioPCI) Line port. Using this setup with xawtv - and the Line port
> > *not* muted - works fine: I can hear the channel I'm currently tuned
> > to in real time. Generally, audio playback (using mpg321, KDE system
> > sounds etc) separate from MythTV works fine on my system as well.
> >
> > The issue is with recorded content, including "Live" TV - there is an
> > audio stream in the files (my video analyzers all report there is a
> > 128kbit MP3 stream present) but it is dead silent. While in MythTV,
> > disabling mute on the Line port allows me to hear the channel (albeit
> > delayed, because of the encoding overhead of Live TV) being tuned to,
> > but the moment I enable mute as I'm supposed to I can no longer hear
> > the audio.
> >
> > I've tried to mute the Line port, tune to a channel using xawtv and
> > then 'aplay /dev/dsp' but that results in nothing but a few clicks and
> > then nada - it reports a frequency of 8000bits (shouldn't that be
> > 32000?) and mono (shouldn't that be stereo?), gives a few underrun
> > errors like it's supposed to, and then stops.
> >
> > I've also tried to tinker with the settings in the Myth frontend, such
> > as setting the audio device to ALSA:default and the Device to default
> > - no apparent errors, but no sound either. Besides, since I have no
> > audio content in my recorded files I presume the problem is with the
> > backend rather than the frontend.
> >
> > When configuring a capture device using mythtv-setup, there is an
> > option for audio device which is currently set to /dev/dsp. Is that
> > correct? Should it be changed to something - esp since I'm trying to
> > use all ALSA devices to narrow down the problem? Is there a more
> > low-level way - ie not so MythTV specific - to test recording audio
> > from an analog tuner?
> >
> > Any assistance greatly appreciated.
> > _______________________________________________
> In alsamixer, if you hit F4 it will take you to the capture options.
> In there should be your answer.  Changing the capture device to the
> Line-in (assuming that's how it's connected) and increasing the
> capture volume will hopefully fix that up.  All of the rest of your
> settings all sound pretty accurate, however it's been a while since I
> used one of my bt87x based cards.
> Good luck!
> -Chad
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list