[mythtv-users] MythTV + AC3 question

William Munson wmunson at rochester.rr.com
Fri Aug 25 17:18:40 UTC 2006

Drew Bernat wrote:
> With everything set up and (mostly) working, I've turned to getting my 
> HDTV-recorded programs (via a PCHDTV-5500) to output using AC3. I 
> looked through the archives and found a thread with similar symptoms 
> to mine, but no resolution. 
> The setup:
> PCHDTV-5500 recorded programs
> NForce 4 sound, ALSA, snd_intel_hda module (the MSI 6150 motherboard)
> MythTV internal player (mplayer et. al. work at this point). 
> MythTV WIKI asoundrc file (in /etc/asound.conf)
> I've tried the following configurations with the included results. I'm 
> wondering if this seems familiar to anyone:
> Sound output = ALSA:spdif or ALSA:iec958
>   - ALSA complains about a nonexistent device (?)
> ALSA:hw:0.2 (the IEC958 output) or plughw:0.2
>   - "AC3 passthrough" checked: static on all speakers
>   - "AC3 passthrough" unchecked: overdriven audio out of right front 
> channel only; I can hear the program, but it sounds like a blown speaker. 
> ALSA:hw:0 or plughw:0
>   - "AC3 passthrough" checked: no sound
>   - "AC3 passthrough" unchecked: sound, but it's being decoded by Myth 
> and coming out on analog + digital
> When I was using hw:0.2 and "AC3 passthrough" checked it appeared as 
> though Myth was still using an internal decoder:
> 2006-08-24 05:22:52.810 AFD: Looking for decoder for MPEG2VIDEO
> 2006-08-24 05:22:52.834 AFD: Opened codec 0x7d5e50, id(MPEG2VIDEO) 
> type(Video)
> 2006-08-24 05:22:52.874 AFD: Stream #1, has id 0x84 codec id AC3, type 
> Audio at
> 0x0x79b390
> 2006-08-24 05:22:52.909 AFD: Looking for decoder for AC3
> 2006-08-24 05:22:52.927 AFD: Opened codec 0x7c8e70, id(AC3) type(Audio)
> Has anyone had a similar problem and managed to get it worked out? The 
> oddest thing to me is the overdriven output on the right front channel 
> - I'm not familiar with anything that would cause such symptoms. 
The lack of sound devices is most likely your problem. Depending on how 
you update your system you might want to install the alsa-devices package.

More information about the mythtv-users mailing list