[mythtv-users] MPEG-2 seektable problems

jonny Linux jonnylinux at gmail.com
Sun Aug 13 12:23:31 UTC 2006


I'm running SVN (from a couple of days ago), with two DVB tuners.

This morning I noticed some MPEG-2 recordings (all the ones I tried - so
presumably all) were having problems with seeking - when I pressed the right
arrow key to skip 5 seconds it moved by a couple of minutes, after pressing
the key about 5 times, the position marker moved to the end of the program
length and wouldn't let me skip any more. I know this is to do with a
corrupted seek table, so I ran optimize_mythdb.pl and my recordings now work
fine except for the two programmes I recorded last night which wouldn't play
at all.

So I tried rebuilding the seektable for those recordings using the command:
mythcommflag --rebuild -f filename.mpg

but the 57 minute program has now been detected as being 4 hours 27 minutes
long, and using the arrow keys to navigate round the file produces the same
problems as described above.

I've also had this problem for a long time using the Internal player for
MythVideo, is there anything that can be done to fix it?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060813/9171549a/attachment.htm 

More information about the mythtv-users mailing list