[mythtv-users] software tuner and pvr-150 in the same system

Raphael Pooser rpooser at gmail.com
Mon Apr 17 21:09:04 UTC 2006

Brian Wood wrote:
> On Apr 17, 2006, at 2:19 PM, Raphael Pooser wrote:
>> Howdy folks.  Haven't been around this list for a while.  Mythtv
>> maintenance has been on the backburner for me now that things are  
>> mostly
>> working.
>> However after searching it doesn't seem like anyone has discussed  
>> this.
>> I just upgraded to a pvr-150 and it works like a dream.  The general
>> howto in the ivtv wiki is the definitive way to go for me; works in  
>> any
>> distro, and was the only howto that worked for me.  Ok I guess that  
>> was
>> some kind of plug for the ivtv wiki howto... sheesh.
>> Anwyay, Now I have my old ATI TV Wonder pro just sitting there.
>> I was wondering if I could get the two tuners to coexist.  So far,  
>> it's
>> trivial to have both working in linux; they do, nothing preventing
>> that.  But having both tuners defined in mythtv causes some...  
>> problems.
>> Basically the way myth is set up it will select video0 to watch  
>> live TV,
>> or it will select the lower priority tuner to watch Live TV if another
>> tuner has a higher priority to be reserved for recording and you've  
>> got
>> the option enabled in the myth settings.
>> Problem is, I can watch live TV with either card, but can't record  
>> with
>> either of them.  Recordings basically confuse the hell out of the
>> backend and it sits there doing nothing.  Tells me it's recording,  
>> shows
>> me a file in my recorded programs list.  But the file is zero bytes  
>> big
>> and trying to select it crashes mythtv.  Telling it to stop recording
>> also has no effect, the backend goes on thinking it is recording  
>> until I
>> kill it.  Restart it and boom, it continues recording nothing.  Do
>> mythtv-setup and remove one of the cards, and magically it can record
>> and watch liveTV without problems, and I can delete the "fake"
>> problematic recording without crashing.
>> So, for now I obviously have the software tuner disabled and am using
>> the pvr-150.  Anyone know if it's possible to have the software and
>> hardware tuners working at the same time?
>> Forgot to mention, the software tuner uses the cx88 driver, and I'm
>> using 0.18.1.
>> It's not a huge deal, but would be nice not to have the software  
>> card go
>> to waste now that it's deprecated.  Thanks all.
>> Raphael
> Also have a look at your logs, might give you a clue as to what's  
> happening.
Oops, first rule before posting, broken... brb ;)  [goes to look at logs]

More information about the mythtv-users mailing list