[mythtv-users] power failure - now lirc stopped working

Brian Wood beww at beww.org
Tue Apr 4 14:49:32 UTC 2006

On Apr 4, 2006, at 8:14 AM, Lucien D. wrote:

>>> srw-rw-rw-  1 root root  0 Mar 30 23:49 /dev/lircd
>>> /dev/lirc:
>>> total 0
>>> crw-rw----  1 root root 61, 0 Mar 30 23:52 0
>> Not sure I completely understand what you have here.
>> I would have expected something like mine :
>> ls -l /dev/lirc*
>> lrwxrwxrwx  1 root root     5 Mar 22 12:59 /dev/lirc -> lirc0
>> crw-------  1 root root 61, 0 Mar 22 12:59 /dev/lirc0
>> crw-------  1 root root 61, 1 Mar 22 12:59 /dev/lirc1
>> crw-------  1 root root 61, 2 Mar 22 12:59 /dev/lirc2
>> srw-rw-rw-  1 root root     0 Mar 22 12:59 /dev/lircd
>> There are multiple character devices because I have 3 PVRs with i2c
>> remote interfaces.
>> Note the socket device just as you show, but I don't understand what
>> you are showing for the character device, it should be /dev/lirc and/
>> or /dev/lirc0, if it is simply called "0" in the directory /dev/lirc
>> it is not going to work, at least in my limited experience.
>> Actually this could depend on your LIRC options. You should have
>> somewhere a configuration file for lircd, it might be /etc/sysconfig/
>> lircd or it might be /etc/conf.d/lircd, depending on your system. In
>> any case it might have "LIRCD_OPTIONS" which should point to the
>> correct character device, otherwise I think it defaults to /dev/lirc.
>> You might try making links, "ln -s /dev/lirc/0 /dev/lirc" and "ln - 
>> s /
>> dev/lirc/0 /dev/lirc0"
>> Then restart lircd and see if you still get the error. This will at
>> least put the devices where they are in my (working) system, which is
>> all I have to compare it with right now.
> Its set to point at /dev/lirc/0 in /etc/conf.d/lircd, and I tried
> forcing the device when running irrecord.  Remember, this was all
> working fine before the sudden power outage.

OK, so we know the device exists and that your system is pointed at it.

Trying to look at this logically, the problem is either related to  
the power hit, or to the fact that you re-booted. Often people make  
changes, sometimes inadvertently, that don't show up until after a  
reboot, even though the actual "problem" was created days or weeks  

If you are sure this is not the case we are left with three  
possibilities: hardware, firmware or software.

It couldn't hurt to re-install anything related to the remote system  
on the odd chance that a bit or two got mucked up that fsck didn't  

Then you want to be sure that nothing in your BIOS setup got changed  
that might affect the port your remote is connected to.

If these two things are not the problem you are left with:


The only real way to troubleshoot this without test gear that you are  
not likely to have is by substitution. I really don't know any other  

Not a great answer but what else is there ??

More information about the mythtv-users mailing list