[mythtv-users] Accessing MythWEB from Docomo I-mode

Ciaran ciaranj at gmail.com
Fri Sep 23 08:40:05 UTC 2005

Round and round we go ;) As I tried to explain before, WAP is the
protocol that is used for data transmission between the phone and its
WAP gateway [main point of connection to t'internet].  What you're
*really* asking about is WML , which is the language used to build up
screens on traditional WAP based phones.

I'm not sure of the specifics of CHTML, but if it's close enough to
HTML then the mobile HTML theme may just work for you, if you've added
your user-agent substring to the list of the supported agents, if your
phone is sending a HTTP-ACCEPT header that contains text/html then you
should automatically get the HTML theme rather than the WML theme
delivered [at least thats how the code appears].  If you use that
netcat (nc -l -p 80) trick I described earlier you can find out what
HTTP-ACCEPT header your phone is actually sending, and thus begin to
work out why you're not receiving the perhaps more useful for you HTML

[For what its worth that bit isn't working for me at the moment and
I've had to hard-code the code to alwas return the HTML theme, as it
refuses to serve me anything by WML ;) ]

- Ciaran

On 22/09/05, David Bennett <davidbennett1979 at gmail.com> wrote:
> Hello!
>  Thanks for your help so far. Here is the problem. I-Mode docomo
> phones operate on CHTML and not WAP. I have found the user agents
> section in includes/init.php, but since Docomo does not use WAP I am
> not sure what to do.
> Is there a chtml theme for mythweb?
> Does anyone have IMODE working with MythWEB?
> I have tried using the wml theme as well, but with no luck.
> Any suggestions?

- Ciaran
(I now have far too many G-Mail invites available, anyone who wants
one, gets one)

More information about the mythtv-users mailing list