[mythtv-users] Mythweb won't delete programs

Neil Neil.myth at blueyonder.co.uk
Mon Oct 31 17:06:55 EST 2005

On Thu, 2005-10-27 at 14:32 +0200, Chris Rouch wrote:
> On 10/21/05, Chris Petersen <lists at forevermore.net> wrote:
> > ok, to put all fears to rest about this being a code issue, I can
> > confirm that it works perfectly for me as of SVN revision 7538 (current).
> >
> > On to the next set of problems..  why this is happening to Neil.
> Is it an selinux issue? A look through the apache logs should show
> error messages if it is, or if it's any other kind of permission
> problem.
> Chris

Sussed out what the problem was - it was because I'm stooopid!

When I first installed mythtv I did it from a package. Despite having a
dvb card that outputs mpeg2, mythtv was creating .nuv files - something
XBMC (which I use to actually watch the programs) couldn't recognise. So
I setup mythrename.pl with the --link<dir> option as a cron job. This
created nice links with .mpg extensions.

When I subsequently built myth from CVS (and then, following advice
here, SVN) enabling dvb in the config meant that instead of
creating .nuv files it created .mpg files. I'd totally forgotten that
when I saw this, I took the --link<dir> option off of the mythrename
script, so it was renaming the original files instead of creating links.
Of course mythweb couldn't delete these files - they had different
filenames to those in the db!

Have reinstated the --link option and all is working well again.

Thanks for all the suggestions - sorry for being such an idiot and
wasting your time!


More information about the mythtv-users mailing list