[mythtv-users] different versions on frontend and backend

Robert Johnston anaerin at gmail.com
Sun Oct 30 13:16:50 EST 2005

On 30/10/05, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> Andrew McNabb wrote:
> Myth is not designed to allow the use of different versions of the
> mythfrontend and mythbackend


> (note that both come from a single project
> directory called "mythtv" and don't allow building the frontend without
> the backend or vice versa).

Incorrect. You can pass --disable-frontend and/or --disable-backend if
you want to make a FE-Only or BE-Only machine.

> As a matter of fact, the same applies to
> mythplugins--you need the same version of mythplugins as the version of
> mythtv.

That's also incorrect. MythPlugins have to be built against the same
version of libMyth, but you can take an old version of the plugins
source, as long as it's built against the same version of libMyth as
the MythFrontend you are wanting to load them from.

> So, if you want to play with SVN and they don't want to, you'll have to
> set up another "test" server.

That's true.
Robert "Anaerin" Johnston

More information about the mythtv-users mailing list