[mythtv-users] Re: lircd starts fine, but crashes as soon as something tries to use it

Jon Kunze jon99ut at gmail.com
Mon Oct 17 09:34:53 EDT 2005

I tried the symlink, and it seemed to work... until i rebooted.

So now I've got bigger problems. Like before, I uninstalled lirc via yum and
then tried to reinstall yum, which fixed the problem before, but only until
I rebooted.

I did the following

# yum remove lirc-kmdl-$KVER
# yum remove lirc

then I did

# yum install lirc-kmdl-$KVER
This line fails as it says there is no match for my kernel
# yum install lirc
This one goes fine

Then I do the

# /sbin/depmod -a
# /sbin/modprobe lirc_i2c
No moduble lirc_i2c found
# /sbin/chkconfig lircd on
# /sbin/service lircd start [OK]

Then when I run either irw or mythfrontend, I get "lircd dead, but subsys
locked" again.

Any ideas on this? Unfortunately I'm at work right now, so I can't put the
exact error messages in this email, but I will be able to later tonight if
anyone has any ideas. Thanks.

On 9/30/05, Nick <knowledgejunkie at gmail.com> wrote:
> On 30/09/05, Jon Kunze <jon99ut at gmail.com> wrote:
> >
> >
> > ---------- Forwarded message ----------
> > From: Jon Kunze <jon99ut at gmail.com>
> > Date: Sep 29, 2005 7:08 PM
> > Subject: Re: [mythtv-users] Re: lircd starts fine, but crashes as soon
> as
> > something tries to use it
> > To: Nate Thompson <nightstrm at gmail.com>
> >
> > Ok, when I try the symlink, it says /dev/lirc already exists. Any ideas?
> > Removing the /dev/lirc and the doing the symlink goes through, but still
> > when I start the frontend lirc locks.
> Does the LIRC log give any useful info when it fails now?
> You can also start lircd using the parameter --device=/dev/lirc0 -
> does this work at all?
> Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20051017/4779bac4/attachment.htm

More information about the mythtv-users mailing list