[mythtv-users] Buffer underrun/audio stuttering

Curtis Stanford curtis at stanfordcomputing.com
Fri Nov 25 11:15:28 EST 2005

On Nov 25, 2005, at 12:02 AM, Michael Sciscenti wrote:

> I've tried to avoid emailing the list until I was absolutely sure I  
> couldn't get any further without help.
> I'm trying to get a Mythtv frontend/backend server up and running  
> on a P4 2.8 GHz box with 1 GB RAM and Nvidia Geforce 6800. HDTV  
> over firewire is what I'm having trouble with. I can now reliably  
> connect to the cable box and get HDTV streams using test-mpeg2 and  
> in Mythtv itself, however I've been completely unsuccessful at  
> solving my audio stuttering problem. I've tried every combination  
> of settings and every little suggestion I could find on the  
> internet and this list yet I still get the following errors:
> 2005-11-24 04:33:52.663 audio waiting for buffer to fill: have 2048  
> want 4096
> or
> 2005-11-24 04:33:54.567 WriteAudio: Preparing 4096 bytes (1024 frames)
> 2005-11-24 04:33:54.568 WriteAudio: buffer underrun
> Things I've tried but none have gotten rid of the stuttering:
> ALSA, OSS emulation through ALSA, an asoundrc is present, Xvmc on/ 
> off, deinterlacing (bob) on/off, extra sound card buffering on/off  
> (the TV settings option), agressive buffering on/off (in General  
> settings), priority process on/off, etc, you name, I've tried it.
> The problem exists in both the current release of mythtv and svn  
> from two days ago. I'm running Gentoo. Does anyone have any  
> suggestions?
> My configure setting:
> ./configure --disable-distcc --prefix=/usr --mandir=/usr/share/man  
> --disable-altivec --disable-xvmc-vld --disable-directfb --disable- 
> audio-oss --disable-directx --enable-firewire --disable-audio-jack  
> --disable-joystick-menu --enable-lirc --enable-xvmc --enable-opengl- 
> vsync --enable-xv --enable-x11 --enable-proc-opt --disable-dbox2 -- 
> disable-ivtv
> Also of note, I'm using a PCI firewire card that has a VIA chipset.  
> Some have said there are issues with these, but I dont think its  
> the source of my problems since I'm able to grab streams fine using  
> test-mpeg2 and they playback perfectly in mplayer using xvmc. My  
> motherboard is a SiS chipset.
> Any help would be awesome, I'm about at my wits end and starting to  
> look at other platforms, but really would like to stick with myth  
> if possible. Thanks.

I had the same problem with XvMC on. Works fine with it off, however.  
I'm using FX5200 and P4 2.4GHz and firewire on DCT-6200.
By the way I also have a cheap $20 PCI firewire card with the VIA  
chipset and it works fine. Sometimes, my node switches on me (0 to 1  
or 1 to 0) for no apparent reason, but otherwise it works well.


More information about the mythtv-users mailing list